My Armada 2 Federation Constructions ships dont move -1 reply

Please wait...

steel2

shuboobala

50 XP

10th June 2004

0 Uploads

23 Posts

0 Threads

#1 14 years ago

I was adding some new ships into my federation AI build list thingy, and now when ever i start up a new game the federation construction ships just sit there, i think it was something i did with the AI, i copied some fresh AI files from another copy of A2 i have on my computer and they still sit there, can anyone tell me what to do?!?!?!




Twitch1

The Borg will rock your world!

50 XP

4th December 2003

0 Uploads

319 Posts

0 Threads

#2 14 years ago

If you went back to the original AI files they should go. I have found that certain maps produce lethargic action at start up where races just sit there. Part seems to be their relative start position. I have no idea why. Does this happen on all maps tried? I hate to say it but a re-install may help. That's a lot of work if you have a bunch of mods as many do, I know.

One thing that screws up the AI is putting something in a build list in the wrong place like adding a ship build line before its yard and/or required other station has been built. This requires checking the techtree files.




steel2

shuboobala

50 XP

10th June 2004

0 Uploads

23 Posts

0 Threads

#3 14 years ago

Ya, the day after i posted this, i decided to re-install my main copy of A2 it took me the whole day 2pm-12am to get everything back to the way it was. but just now i tried again to replace my "fscout" with "fnova" (Nova Class) in the 5 Federation AI files, i just replace the name "fscout" with "fnova" and when i launched a fresh game they stood there again. but luckly, this time i backed up the five fed ai files. I wish it would work, i havent been able to figure it out yet.

Thanks for posting ur suggestions




Porty

Warrior Ant

50 XP

21st August 2002

0 Uploads

505 Posts

0 Threads

#4 14 years ago

Have you thought of renaming "fnova" to "fscout" instead of changing the AI files??

Just a thought!! ;)




Twitch1

The Borg will rock your world!

50 XP

4th December 2003

0 Uploads

319 Posts

0 Threads

#5 14 years ago

Oh yeah Porty, I think you got something. If you have a ship called fnova edited in the AI files the race odf might conflict and get dumb since it has starting units named as fscout.odf.

Look in this part of Fed.odf in odf/other folder--

// the things you get when you ask for minimal default units (instead of the map units) minimalUnits1 = "fconst.odf" // construction ship

// the things you get when you ask for standard default units (instead of the map units) standardUnits1 = "fconst.odf" // construction ship standardUnits2 = "fconst.odf" // construction ship standardUnits3 = "fbase.odf" // starbase standardUnits4 = "fscout.odf" // starbase

// the things you get when you ask for superside units (instead of the map units) superUnits1 = "bconst.odf" // borg construction ship superUnits2 = "fconst.odf" // federation construction ship superUnits3 = "kconst.odf" // klingon construction ship superUnits4 = "rconst.odf" // romulan construction ship

ctfUnits1 = "ctf_fbase.odf" ctfUnits2 = "ctf_fconst.odf" ctfUnits3 = "ctf_fconst.odf" ctfUnits4 = "fscout.odf"

SO Steel you could change the fscout.odf to fnova.odf in the fed.odf file and see what happens.




steel2

shuboobala

50 XP

10th June 2004

0 Uploads

23 Posts

0 Threads

#6 14 years ago

Thanx, i'll give it a try