Strangest bug ever -1 reply

  • 1
  • 2

Please wait...

k_merse

Evolution

50 XP

30th September 2007

0 Uploads

637 Posts

0 Threads

#1 9 years ago

I found the strangest bug I ever met modding A2. I rescaled Fahres' TOS ships to fit perfectly in size to the other models, but I experienced, that the Constitution is significant smaller than it should be. The scaling is OK, so it can't be the problem. But not this is the strange part. When I switch to 3D view, the Connie's scale switches to normal! She gets the perfect size, just as set, but when I switch back to 2D, the Connie gets smaller again. Does anyone have an idea what's happening?




Guest

I didn't make it!

0 XP

 
#2 9 years ago

I've had a similar thing happen with the Reliant retexture. In 2D, she was about twice the size of ENT-A. Yet when I switched to 3D, she was the correct size. I went back to the original Reliant SOD and the problem resolved itself. I thought it was something I had done until seeing this thread. Maybe reverting to a previous version of FahreS' Connie will work for you? As to why it happened I have no clue. Although I did notice when swapping the SOD for the previous one, the problematic one had a significantly larger file size, nearly 15KB larger.




Amateur

beginner on armada2files

50 XP

23rd April 2005

0 Uploads

398 Posts

0 Threads

#3 9 years ago

Now that's a bug... I can't think of anything that could cause that though - the same model and coding is used and there should be no changeover occurring... I think Thunderfoot's suggestion is the best idea - try that. If not then I have no idea... (Now that is a lot of ellipses...)




Avon

Ageing Rapidly

50 XP

26th October 2006

0 Uploads

483 Posts

0 Threads

#4 9 years ago

na it's not a bug. There is a line in the rts-cfg that refers to a percentage increase when in 3d mode..

i'm not at my pc at the moment to check what it'r called. Basically you need to change it so the views are the same.

for some reason it causes havoc when you use scalesod on certain models




Dan1025

Adopt, adapt, improve

50 XP

23rd February 2007

0 Uploads

1,454 Posts

0 Threads

#5 9 years ago

Avon's right, its a command in the RTS_CFG file, search for the word "scale" and you should find it straight away, you need to set the value to 1.0 so the ships are the same size in both view modes. I've pasted the command from my RTS_CFG file so you can see what its called:

// What's the maximum strategic view scale factor? float cfgMAX_STRATEGIC_VIEW_OBJECT_SCALE = 1.00;



Guest

I didn't make it!

0 XP

 
#6 9 years ago

Thanks guys. I appreciate it. Done.




k_merse

Evolution

50 XP

30th September 2007

0 Uploads

637 Posts

0 Threads

#7 9 years ago

Thanks! It worked me, too.




DarkEnergy

a basin of water

50 XP

12th April 2006

0 Uploads

459 Posts

0 Threads

#8 9 years ago

looks like we should start a rework of the RTS_CFG file as well....




Guest

I didn't make it!

0 XP

 
#9 9 years ago
DarkEnergy;4952207Looks like we should start a rework of the RTS_CFG file as well....

Once again, the Other Old Guy =p is quicker off the mark than the rest of us. All the proof one needs with age comes experience and great wisdom.




Warborg

Revenge was here.

50 XP

2nd August 2002

0 Uploads

1,833 Posts

0 Threads

#10 9 years ago

I never had this problem, but with MU2.0, My Latinum moons are very very large while doing map editing but ok while running the game.




  • 1
  • 2