Custom Enterprise System -1 reply

Please wait...

Admiral Janeway

Slightly cooler than a n00b

50 XP

15th April 2004

0 Uploads

44 Posts

0 Threads

#1 14 years ago

Is there a way to make a custom system? I was looking to modify the 'Earth' system to make it resemble the time period from Enterprise. Does anyone know how to do this?




elminster

Bridge Commander Master HPer

50 XP

26th October 2002

0 Uploads

1,448 Posts

0 Threads

#2 14 years ago

Check this thread, it may be of some use; http://www.gamingforums.com/showthread.php?t=62766




Admiral Janeway

Slightly cooler than a n00b

50 XP

15th April 2004

0 Uploads

44 Posts

0 Threads

#3 14 years ago

I already looked at that. I just want to replace the ships that are in the system with others. Like the Nebula Class by the moon would be replaced by a Vulcan ship.




MilleauRekiir

I follow teh Moo!

50 XP

4th November 2003

0 Uploads

631 Posts

0 Threads

#4 14 years ago

Yes, each system has two files associated with it. One defines points where things are going to be placed, the other defines what goes in there. If you alter the second one, replacing the nebula with the Vulcan ship for example, you can swap round ships and stuff. They are located in the folder scripts/system/ and an example would be the Romulus map where the thing you'd change would be Romulus1_S.py. Once you get in there and see how ships are added, you'll know what to look for in other maps.




Admiral Janeway

Slightly cooler than a n00b

50 XP

15th April 2004

0 Uploads

44 Posts

0 Threads

#5 14 years ago

I was here a few days ago and I did figure out how to add ships to a system. BUT, when I try to play the system, I'm stuck on the bridge and can't move. the console drop-down says I have made an 'Illegal arguement type for built in operation.' And then it gives me something about splash damage from the ships. Does anyone know how to fix this? :( :confused: :(




Admiral Janeway

Slightly cooler than a n00b

50 XP

15th April 2004

0 Uploads

44 Posts

0 Threads

#6 14 years ago

OK, I fixed that problem, but got a new one: When I enter the system, the ships that I added EXPLODE for no good reason! I space their starting points apart, but that doesn't help! I've looked around, but can't find the problem!!??!!?? I know I sound like a complainer, but this is the first time I've ever done this and some of it is still confusing.




Wormhole

Big BC fan....but no comp wiz

50 XP

11th February 2004

0 Uploads

45 Posts

0 Threads

#7 14 years ago

That a new one on me:confused: :confused:




elminster

Bridge Commander Master HPer

50 XP

26th October 2002

0 Uploads

1,448 Posts

0 Threads

#8 14 years ago

Threads merged