lightsaber turned into sword? -1 reply

Please wait...

Kash

I'm too cool to Post

50 XP

14th July 2003

0 Uploads

2 Posts

0 Threads

#1 15 years ago

Erm...

Well, I entered a random dueling server, but when I went in I was surprised to find that the lightsaber blades were thin white... things, and they had sword sounds. I figured it was some server side mod, and shrugged it off.

Later, I went to another server and... the new blade and sounds stuck. This is... weird to say the least. Any ideas on how to get my blades and sounds back?




BenZB

I do spend enough time here

50 XP

6th July 2003

0 Uploads

39 Posts

0 Threads

#2 15 years ago

You probably joined a server running JediMOD or some other mod that makes it so you can change the color of your saber. The default color is black for these MODs.Try creating your own server offline and your saber should go back to normal.:D




tyriel

Waiting For Half-Life 3...

50 XP

28th November 2002

0 Uploads

1,393 Posts

0 Threads

#3 15 years ago

if you downloaded some swords stuff and didn't delete it from your base then you'll still have it, delete it from your base!




kylek

Helpful Mind

50 XP

22nd March 2003

0 Uploads

2,158 Posts

0 Threads

#4 15 years ago

It's probebly because neither were pure servers so all of your files would work meaning any skins, maps, models, etc, could have had a bug which causes it.

To fix take them out then place in one by one but put one in then play jk2 until that problem accures then take out the last file you put into base and put the rest back in then delete the file with the bug in.

First test out jk2 and see if it happens on your own server, if it does not then ignore what i've said.

Good luck on finding the file with the bug in.;)




Kash

I'm too cool to Post

50 XP

14th July 2003

0 Uploads

2 Posts

0 Threads

#5 15 years ago

The problem continues on my own server... and my base folder is mess :(

I'm gonna have a field day with this one.




8_Balller

I see holes like eyes!

50 XP

7th April 2003

0 Uploads

94 Posts

0 Threads

#6 15 years ago

u have proibly got a sword hilt in your base folder, try running sp and if it is still appearing on ur saber you definatly have a blade mod running in your base




kylek

Helpful Mind

50 XP

22nd March 2003

0 Uploads

2,158 Posts

0 Threads

#7 15 years ago

I just said emty your base folder then it should work so read what i said and do it or you probebly will have the problem for a while.

I have an idear, emty your base folder and leave the files in this screenshot.

By the way you can have any folders in there you like but no pk3's other than the ones in the screenie.:D

Good luck




Marker0077

Some n00b that binds specials

50 XP

10th August 2002

0 Uploads

1,284 Posts

0 Threads

#8 15 years ago

Originally posted by Kash Erm... Well, I entered a random dueling server, but when I went in I was surprised to find that the lightsaber blades were thin white... things, and they had sword sounds. I figured it was some server side mod, and shrugged it off. Later, I went to another server and... the new blade and sounds stuck. This is... weird to say the least. Any ideas on how to get my blades and sounds back?

The thin white saber part is something we do in Duelers mod for sword hilts. It's so you do not see a glow around swords while using them.

The sounds on the other hand is on your end. That is a mod in your base folder or whatever mod folder. Make a sub-folder in base & move all the .pk3 files in that folder, EXCEPT for the assets .pk3 files. That should resolve your problem. You will have to figure out which .pk3 it is that has those sound files in it. You should be more careful about what mods you choose to use.