Textures problems -1 reply

Please wait...

Ghetto-Thuggin

I'm too cool to Post

50 XP

29th March 2004

0 Uploads

2 Posts

0 Threads

#1 15 years ago

Hi There, Im having some problems with the textures in JK2. When I play It works fine for a while then When I step or shoot or something anything at all the textures suddenly go all funky with different colors and the lighting goes weird. It dosent change back until you Either log off or shut down and it is getting pretty annoying since i cant read any text either and this happens again and again. I had a built in bullshit graphics card (SiS summat came built into my motherboard) and allthough it was slow it never had any problems like this. Then I got hold of an GeForce 4 Ti 4200 (64mb DDR Ram) the graphics and speed are alot better but Im getting this annoying problem now. I get something similar to this when playing raven shield and occasionally on halo but on both of these it either dissapears after a while or on raven shield i use the 'flush' command and it dissappears. I looked in my Geforce manual and it said something about flickering textures and how to get rid of them it said for quake 3 but i think they're both running the same engine so i typed it in anyway...here's what it said: Type the following at the console: /r_ext_compiled_vertex_array 0 /vid_restart then the game restarts and i have the same problem. Im not sure what to do anymore i have the latest nvidia drivers and am running windows xp professional my stats are below. ++ MACHINE STATS ++ Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 1 (2600.xpsp2.030422-1633) Language: English (Regional Setting: English) System Manufacturer: n/a System Model: n/a BIOS: n/a Processor: AMD Athlon(tm) Processor, MMX, 3DNow, ~1.2GHz Memory: 256MB RAM Page File: 224MB used, 369MB available Windows Dir: C:\WINDOWS DirectX Version: DirectX 9.0b (4.09.0000.0902) DX Setup Parameters: Not found DxDiag Version: 5.03.0001.0902 32bit Unicode ++ GRAPHICS CARD STATS ++ Card name: NVIDIA GeForce4 Ti 4200 Manufacturer: NVIDIA Chip type: GeForce4 Ti 4200 Display Memory: 64.0 MB Current Mode: 800 x 600 (32 bit) (60Hz) Monitor Max Res: 1600,1200 Driver Name: nv4_disp.dll Driver Version: 6.14.0010.5664 (English) Driver Attributes: Final Retail Thanks alot to anyone who can help out




MeusH

°•°•°•°•°•°•°•°•°

50 XP

16th November 2003

0 Uploads

3,282 Posts

0 Threads

#2 15 years ago

You said that you see freaky colors as shot-marks, and strange lights after shooting, right? Move all pk3s (except assets 0,1,2) from base folder, to some temp folder. Check that JK2 works. If yes, restore (move back to 'base' folder) every pk3, and check what pk3 was corrupted




Ghetto-Thuggin

I'm too cool to Post

50 XP

29th March 2004

0 Uploads

2 Posts

0 Threads

#3 15 years ago

I just tried that now same problem I only had to remove one pk3 (assets5.pk3) since it was a fresh install of JK2 and its still having the same problem cant read text grpahics all funny. I think it might hae something to do with my card or drivers but im not sure.




aidy1972uk

As Helpful as I can be

50 XP

2nd April 2003

0 Uploads

279 Posts

0 Threads

#4 15 years ago

Assets5.pk3 is part of the game I think (MIGHT be something to do with a Mod like JediPlus, its been so long since I've played/made mods for JK2 I can't remember!) anyway, first off try uninstalling all drivers for graphics card and reinstall the latest ones, then go to you're device manager and try to find the onboard graphics and disable it - JK2 MIGHT still be trying to run off those since it has been PC's default before you're upgrade. I know you're monitor is plugged into the new card but its worth the try... Also (again can't remember) see if there is a setting in JK2 for what device to use. Finally, before you start a game of JK2 set ALL graphic settings to the lowest possible available and see if you get similar problems. I had what sounds like you're problem on the demo of Deus EX recently and I couldn't get around it and my system is way above average to high end. Hope this is of some use to you, although its a good chance that you've already done most of this!! Good luck. Aidy.




MeusH

°•°•°•°•°•°•°•°•°

50 XP

16th November 2003

0 Uploads

3,282 Posts

0 Threads

#5 15 years ago
MeusHYou said that you see freaky colors as shot-marks, and strange lights after shooting, right? Move all pk3s (except assets 0,1,2) from base folder, to some temp folder. Check that JK2 works. If yes, restore (move back to 'base' folder) every pk3, and check what pk3 was corrupted

all pk3s