Unpure server -1 reply

Please wait...

The_Wanderer

I'm too cool to Post

50 XP

15th August 2003

0 Uploads

11 Posts

0 Threads

#1 16 years ago

Hello, I'm trying to run a server with the Win32 Dedicated 1.04 file. The only problem I'm having so far is...What is the cvar or cmd or whatever it's called to make it unpure?

Also, It keeps saying..."Hitch Warning: 17913 msec time frame"

Well, the 17913 thing can be just about any number. But what does it mean? What can I do to fix it? Every time that it says that a bunch of times at once, the game says Connection Interrupted. Help...please...?




IZaNaGI

Mandalorian Jedi

50 XP

14th November 2002

0 Uploads

117 Posts

0 Threads

#2 16 years ago

the hitch warning is lag inside your server, for every 1000 means 1 second of pure lag.

Try to make sure that if your going to run a server you will need at least a ADSL connection and running with a processor of AT LEAST 1gig to make sure that your game doesnt lag it either.

As for the command to make it pure or unpure i dont know it off the top of my head, but it can be set either on or off if u set up a server inside of jk2




sverrearagorn

Knight

50 XP

8th June 2003

0 Uploads

245 Posts

0 Threads

#3 16 years ago

use the "advaced" tool in "creat new game/server" menu. Set "pure" to "no/off". that should unpure your server! :D




EXiT

7o'nine

50 XP

11th April 2002

0 Uploads

2,175 Posts

0 Threads

#4 16 years ago

The command is sv_pure Set it to '0' for unpure.

As for the hitch warning, it's a normal warning. Almost every server will get one. It basically means that your JK2 server isn't getting full access to your CPU. the number represents the amount of time it didn't get complete access to the CPU. The higher the number, the less power the server has to run, therefore it starts to lag. Generally keeping it low (I'd say maybe 1000 or less) is acceptable.

Though also keep note that lag could also be happening because of your connection, the clients connection, traffic between you and the client.. etc..

EXiY




The_Wanderer

I'm too cool to Post

50 XP

15th August 2003

0 Uploads

11 Posts

0 Threads

#5 16 years ago

Well, I was able to get it unpure, thanks to you guys :D But, as of right now, it is only a LAN server. This is because I am behind a network, and later my brother is going to reconfigure the computers in my house to let me host an Internet server. Is it because it is LAN that I am getting such a ridiculous amount of lag? I have a cable connection, where I am always connected and stuff, so my connection is very fast. Usually on a decent server, when there are maybe about 13 other people on the server, well, my ping is somewhere from 50-80, but most everyone else's is above 100. So, unless it is because of the network or LAN, why in the world do I have so much lag???




EXiT

7o'nine

50 XP

11th April 2002

0 Uploads

2,175 Posts

0 Threads

#6 16 years ago

If you're playing on a LAN you shouldn't have lag... but while cable modems can have high download speeds, their uploads speeds can be quite low. For example, my cable runs on average between 700kb-1mb, but my upload almost never goes above 30kb.. so you should check with your ISP what your upload speed should be, and also do some speed tests online to see what it is.

The numbers in the hitch warnings aren't too high are they?

EXiT




The_Wanderer

I'm too cool to Post

50 XP

15th August 2003

0 Uploads

11 Posts

0 Threads

#7 16 years ago

Well, the numbers usually aren't high when I don't play at JediCouncilGC map, but they show up a lot. But sometimes I do get high numbers. It doesn't make sense; I have a fast connection.