Help needed on adding new races -1 reply

Please wait...

Everitt.Cage

Slightly cooler than a n00b

50 XP

18th October 2008

0 Uploads

48 Posts

0 Threads

#1 10 years ago

I would like to add several new races to my game, but I am having a little trouble and would appreciate any help. To clarify, I mean actualy adding a new empire to the map, not combining it with a pre-existing empire. I have sucessfuly added the Rakellians by creating a new map with Rakellian space, and adding the needed ships to the two spec files, but when I tried to do the same with the Cardassians the ships would not load and the game would crash a few minutes into the mission. If anyone has been able to sucessfully add new races to the game, please tell me how you did it. Thanks for the help!




Shadow9216

Slightly cooler than a n00b

50 XP

22nd February 2007

0 Uploads

46 Posts

0 Threads

#2 10 years ago

How did you add the Rakelli? And when you added the Cardassians, what did you do? You have to have one of each type of base when you add a race to the map. Also, check your invalid ships file and see what it says.




AlDaja

SFC III Troubleshooter.

50 XP

5th September 2006

0 Uploads

11,263 Posts

0 Threads

#3 10 years ago

You might want to send a query to Yochenhsieh (Dominion War Mods) @ yochenhsieh(@)gmail(DOT)com. This guy is up on the do and don’t for moding SFCIII and is generally helpful. I have a question. How did you get the game to accept new Rakelli ships other than the two stock options? Whenever I’ve done so the game just ignores them or the stock ships won’t load at all. Is there an asset or meta asset file I need to modify?




Shadow9216

Slightly cooler than a n00b

50 XP

22nd February 2007

0 Uploads

46 Posts

0 Threads

#4 10 years ago

Presumably you're adding the necessary entries into default core and default load out? Have you checked the invalid ships entry? Only other option is there's a mismatched file/model name somewhere.




AlDaja

SFC III Troubleshooter.

50 XP

5th September 2006

0 Uploads

11,263 Posts

0 Threads

#5 10 years ago
Shadow9216;4784613Presumably you're adding the necessary entries into default core and default load out? Have you checked the invalid ships entry? Only other option is there's a mismatched file/model name somewhere.

Yeah, all that checks out. I’m in the process of making a simple campaign mod. I’ve reconfigured the AI to see the Rakelli defense platform and added the shipyard to the core file, which allows Pelican’s Emergency Script to added 3 to 5 enemy ships to the scenario; however, I’ve noticed the game doesn’t seem to like any additional ship additions other than the cannon ones provided by Taldron. I wonder if I add the ships, but just keep the “class” heading under the core file the same if that would work. Example: the default core/outload files only allow for one FF and one CL for both the pirate and Rakelli ships. When I place other ships in the game for either of these races such as CA, BB or DD for example the game will not play them and in scenarios that use the cannon Rakelli or pirate vessels they will not show up either until I revert the file back to the way it was. I can modify HP’s and such but apparently not add other ships to these races, which doesn’t make much sense to me. If I can add ships/stations to the stock races playable in the game why not these? I should mention that I’m just using the map that came with the game and have not added any additions for this. I just want the AI to have more options so when you attack a neutral planet or answer a distress call more ships will show up than the standard stock… EDIT: Is their a hidden Core file in the game? I have noticed that their are models in the outload file that show up in the game if you play Mission's, but can't be found in the core file under the assets file we modifiy.




Everitt.Cage

Slightly cooler than a n00b

50 XP

18th October 2008

0 Uploads

48 Posts

0 Threads

#6 10 years ago

I'm not exactly sure what you guys mean by "invalid ships entry". which file is this and where is it located?




AlDaja

SFC III Troubleshooter.

50 XP

5th September 2006

0 Uploads

11,263 Posts

0 Threads

#7 10 years ago
Everitt.Cage;4784712I'm not exactly sure what you guys mean by "invalid ships entry". which file is this and where is it located?

Right click on your SFCIII icon: "C:\Program Files\Activision\Sfc3\SFC3.exe" Then click on "find target" and open up the text file that reads "Invalid ship.txt" If you have an invalid ship, it will tell you which ship and what's wrong. Most times it's because you overloaded the HP's or placed something invalid on the hull. Most common error is having this in your core file: HP:1:2:3 and doing this in the outload file: F-TRANSPORTER-I:1 F-TRACTOR-I:1 (note "1" is given a value twice, can't do that.) or you have a space in the wrong place, spelled something wrong or have an upper/lower case value incorrect.




Shadow9216

Slightly cooler than a n00b

50 XP

22nd February 2007

0 Uploads

46 Posts

0 Threads

#8 10 years ago

In the main SFC3 folder, there's txt file labelled "invalid ships" if you have any- that usually gives you a place to start when stuff doesn't work.

@AlDaja: I added (among others) the Diamondback cruiser by SSS3. It's added in DLO and DC as Rakellian-Cruiser and Rakellian-Battlecruiser and points to the folder Diamondback. Don't seem to have any issues loading it and having it show up. I added a bunch of Orion ships to the Pirates, I think I've got up to DD6 and CL4, FF4, etc. So the AI has multiple entries to pull from when I attack a Pirate hex.




Everitt.Cage

Slightly cooler than a n00b

50 XP

18th October 2008

0 Uploads

48 Posts

0 Threads

#9 10 years ago

Ok, heres where I am so far. I copy/pasted the two Rakellian ships until I had enough for each class, then renamed what needed to be renamed. I used Federation ship models(saber, norway, intrepid, akira, nebula, and sovereign) so I would know if the game was picking from the whole list, then I created a map with Rakellian space. When I tested in game, the game created CLs and CAs, and when I attacked a base there were Destroyers(norways), Light Cruisers(intrepids), and Cruisers(Akira). That seemed to work well enough so I repeated the process with Species 8472. However, instead of using Fed ships, I used a species 8472 model that I had downloaded for each ship class. I tested in game and had the same results as before. However, the problem is when I tried the process a third time with the Cardassians, the ship model does not load(it appears like an invisible ship). And shortly after getting close enough to fire on the ship, the game crashes. I cant understand why this would work for the Rakellians and Species 8472, but not Cardassians. Any ideas on what the problem might be?




Everitt.Cage

Slightly cooler than a n00b

50 XP

18th October 2008

0 Uploads

48 Posts

0 Threads

#10 10 years ago

LMAO!!! In response to my last post, it was my fault the Cardies werent working. I have several copies of my SFC3 folder that I'm tinkering with, and the model that I was trying to use for the Cardassians wasnt in the folder that I'm doing this testing in. But the good news is that I have sucessfully added the Rakellians, Species 8472, and the Cardassians, and the game is using ships from more than just the first two classes! I'm going to test pirates and Ferengi, then get back go you all :D