'Adding' an existing unit: PLEASE HELP! 2 replies

Please wait...

Admiral Jimmy W

Forum Musketeer

50 XP

22nd March 2003

0 Uploads

249 Posts

0 Threads

#1 16 years ago

This has driven me to the point of distraction. I concede defeat.

Can someone please tell me which files I need to modify to make the UN Soldier a Buidable unit? I have tried all the obvious things such as commandset.ini and commandbutton.ini and it still refuses to work. The game wont even start, it gives me a damned "Technical error".

Is there a file I have missed?




EvilleJedi

GF makes me horny

50 XP

10th March 2003

0 Uploads

85 Posts

0 Threads

#2 16 years ago

the technical error is because something doesn't match up to resources or parse in your code for the unit, best bet is to take the US ranger section entirely and then for just the model and model.model animations replace it with the unsoldier animations, then only change the object name so you can build it, usually the errors I have that give me a technical error are spelling errors when it can't find a resource or can't resolve the data into a valid variable. start with very small changes, don't even modify the cost or health sometimes and you should get a working unit. also make sure all your sections have end tags and the correct format, cut and paste anything like stealth or specal abilites than trying to type it up, once it works that way start modifing it




EvilleJedi

GF makes me horny

50 XP

10th March 2003

0 Uploads

85 Posts

0 Threads

#3 16 years ago

On an Added note, errors that cause the game to not start are scripting errors and probably mean you have an invalid string, tag or value in your unit code

errors that occur ingame and cause the game to crash are the result of a invalid reference, your locomotor, weapon, fx or such are non-existant or you spelled it wrong, if the unit appears in the intro the game will crash before it gets to the load screen and say "serious error" if it isn't in the intro then it will crash when built. check your commandset and commandbutton files and make sure the stuff they look for actually exists, if you need place holders make a unit

Object UNITNAME End

or just take and existing unit and rename its object entry and tell your commandbutton entry to point to UNITNAME

If the unit doesn't show up in the build menu then you probably improperly edited the commandset and command button files

if the unit shows up in the build menu but is unbuildable this may be caused by invalid bone references or errors in the commandset/button files or you forgot to change the side or prereqs

texture errors occur if you use the wrong type of file

Models not showing up are either empty models or non existant files

almost always a technical difficulties message will be caused by improper scripting in the faction***.ini (unit, building), most of the time this bug will be very hard to find and you are probably out of luck and will have to rescript the unit (safest is to make small changes and load constantly and then end task the game if it gets to the intro to see if that change broke anything)

hope this helps people to know where to look if they have errors