model issues. -1 reply

Please wait...

Pestilence64

Battlefield 2 ROX!

50 XP

15th January 2004

0 Uploads

1,126 Posts

0 Threads

#21 15 years ago

personally i have had trouble making animation get used in games on other model iv done, but htat may be because i was using the model as a replacement for original and maybe there was a conflict that prevented it from working but maybe you will have better chance since you will be creating a new unit. heres the code i have been adding cept file name references on other models, copying what i saw in the SecondWave/ZH mod add animation = VirginaClassNSSN.VirginiaClassNSSN animation type = once ;for foreward ooo... i just thought of somethin may not be a problemm tho we'll see, youll be testing but it will be an experiment for me to. but add those lines to the "condition states" you want the animation to occur t open th edoors and then add the same lines to the "condition state" were the doors would close but put animationtype = once_backwards all caps for value fields. ok. i think i know where a prob might arise, i dont know how your going to code the unit so im guessing you may not ahve a place to code for open then close in different condition states, so if thats the case then ill recreat the animation with one clip opening doors wait say 5 then close.




TheMirage

The People's Politsayski

50 XP

25th January 2004

0 Uploads

6,624 Posts

0 Threads

#22 15 years ago

for code I will copy the closest thing there is and make appropiriate changes.:) what prob do you forsee? I may be able to work around it eventually, its all cool though as long as there are no major glitches.;) Mainly what I needed to know was the name of the animation and where to add it, also how to tell it when to use it.

animation = VirginaClassNSSN.VirginiaClassNSSN animation type = once ;for foreward

that may not be a good idea, I belive that applies the animation to the whole model, not just the doors.:uhm: ConditionState = DOOR_1_OPENING Model = AVSGunship Animation = AVSGunship.AVSGunship AnimationMode = ONCE Flags = MAINTAIN_FRAME_ACROSS_STATES ParticleSysBone = WingTip01 SpectreContrail ParticleSysBone = WingTip02 SpectreContrail End ConditionState = DOOR_1_CLOSING Model = AVSGunship Animation = AVSGunship.AVSGunship AnimationMode = ONCE_BACKWARDS Flags = MAINTAIN_FRAME_ACROSS_STATES ParticleSysBone = WingTip01 JetContrailThin ParticleSysBone = WingTip02 JetContrailThin ParticleSysBone = Engine01 SpectreAfterburnerTrail ParticleSysBone = Engine02 SpectreAfterburnerTrail ParticleSysBone = Engine01 SpectreEngineFlare ParticleSysBone = Engine02 SpectreEngineFlare End here is the code for the spectres "doors"(wings) moving; what can you tell me from that?:uhm: and hey, panda man, how are you coming? I just thought, DO NOT skin boaty as a usa building, it is for theGLA. Naval1 is for the USA




Pestilence64

Battlefield 2 ROX!

50 XP

15th January 2004

0 Uploads

1,126 Posts

0 Threads

#23 15 years ago

my gues is that code would work, the animation file is the same as the mosel file cos there the same file. i was just worried if you would have 2 practical Condition states to use for opening and closing the doors, but i guess you found some good code to use. i think im going to go ahead and create a new version with the doors opening and closing as one animation, and then an animation only file for the same you can have different options to make it work.




TheMirage

The People's Politsayski

50 XP

25th January 2004

0 Uploads

6,624 Posts

0 Threads

#24 15 years ago

you probably got my e-mails by now, what do you think about the invisible part? any other ideas incase mine doesn't work? Vangaurd, if you read this, your help is greatly needed.




Pestilence64

Battlefield 2 ROX!

50 XP

15th January 2004

0 Uploads

1,126 Posts

0 Threads

#25 15 years ago

depends on what email address you sent then to, i have a personal yahoo account that doesnt ever work when trying to send attachments, so i send the files vis my work address which i wont post here. if you sent to my work address then i wont get the chance to read them till tommorow. i hope vanguard is reading this, iv noticed his answers usually fix the problem.




Vanguard

Same guy on everyother site.

50 XP

5th May 2003

0 Uploads

544 Posts

0 Threads

#26 15 years ago

What did you need help with?




TheMirage

The People's Politsayski

50 XP

25th January 2004

0 Uploads

6,624 Posts

0 Threads

#27 15 years ago

okay, here we go;

It the submarine. Pestilence agreed to make a model for it, and when I was giving him the specs., I remembered somthing you said to Cammy about the sub in the LOFS mod, that it was below the normal model level to appear to travel below water. I took this to mean that you would move it below the grid surface in g-max, so that is what we did. But when I got the model and added it, it couldn't be seen, and I know its in there because the weapon were obviously launching from different bones, just as I coded it too. But as I said, it can't be seen. so what would you do to make a sub?




Vanguard

Same guy on everyother site.

50 XP

5th May 2003

0 Uploads

544 Posts

0 Threads

#28 15 years ago

Get a picture of it, I think I know your problem, but I can't be sure without actually seeing it.




Pestilence64

Battlefield 2 ROX!

50 XP

15th January 2004

0 Uploads

1,126 Posts

0 Threads

#29 15 years ago

ill post a pic (hopefully it can be seen by you vanguard cos i know you have had problems viewing other i post, and i cant see them either) later tonight from gmax viewport with grid visible, and hopefully you can spot a problem.




Vanguard

Same guy on everyother site.

50 XP

5th May 2003

0 Uploads

544 Posts

0 Threads

#30 15 years ago

No I mean ingame.