Modding tutorial sticky thread -1 reply

Please wait...

Dontai

I want to be like Revenge

50 XP

25th January 2006

0 Uploads

399 Posts

0 Threads

#1 11 years ago

Maybe we should have modding tutorial sticky thread?

[color=red]Good idea, so done - J7[/color]

ODF & DB.PAK files

I haven't mentioned this before and should have, Legacy does not use the ODF files directly by default. It will instead read the DB.PAK file which is a compacted version of all the ODF files in the game. If you make changes to ODF files then you need to regenerate the DB.PAK file. The good thing about this is that sending someone a mod that only affects ODF files is now as simple as sending a single file.

To regenerate the DB.PAK file create a text file called myconfig.cfg in the game directory and in that file add the following:

g_bGeneratePackFile = 1

Then whenever you run the game it will regenerate the file.

If you want to test things and not regenerate files until you are ready I believe you can simple rename the db.pak file and the game will read in the ODFs themselves, however there may be undesired side effects.

Works: 50% of the time Side affects: May not work. May cuase strange errors. None.

How to make skirmish work bit better (the dirty way) Go in to odf after you do the above( if it worked) Then find commandPointCost in the ships you dont want the ai playing and set it to higher amount of points then your gonig to set it for. I ben playing ent era with 5000 point so i'll set all my romulans ship other then scout one the bird of prey hunter (since i think the other are ugly) to 10000. now they have no choice but play scouts. Some balancing required

Works: unkown% of the time Side affects: unknown. May not be blanced.Wont be able to select those ship your self if decide to play them.

how add extra copy of ships to your game (also dirty and imperfect) First take what ever ship you want to copy and copy it (da) like F_NX_03, then go in to m3d and copy the file with same name. You would end up with say F_NX_03.odf and F_NX_03.M3D

Works: unkown% of the time Side affects: unknown. May not be balanced. Wont have selection image of any kind and selection image will most likely show up as box as of now.

Final tutorial:

startYear = 2370 endYear = 2400

Control were ship shows up in game.

Works: unkown% of the time Side affects: unknown. Will cuase ai to crash(not people) if changed.

sort of like this ^^?




O'nieal

Ooopps...

50 XP

28th February 2005

0 Uploads

305 Posts

0 Threads

#2 11 years ago

This was interesting. I'm gonna give some of this a try asap. do you know about importing models? I really want to import a model for an Omega class Destroyer *from B5* I have that might be compatable.




Guest

I didn't make it!

0 XP

 
#3 11 years ago

Dontai, tryed your above suggestions. You said that the .pak regeneration only worked 50% of the time. How many times did you try this before it started to work?

I have tryed the regeneration about 20 times, and although a new .pak file is created, no modifications are added into the game, and the .pak file is still being read as corrupted. Oh, and the odf's weren't being read from the file directories directly when the .pak file was deleted or renamed in the Lagacy folder.

Dontai, you said you had this error and that the methos you outlined fixed it for you... I am curious, what game version is your game, I have installed the patch on mine, now version 1.018 on the Australian retail version. The mods wouldn't work for me before or after the patch... even tryed a fresh reinstall.

:(




Dontai

I want to be like Revenge

50 XP

25th January 2006

0 Uploads

399 Posts

0 Threads

#4 11 years ago

@ O'nieal still looking for a tutorial on importing models, no luck so far. The new modles are in M3D not stander a2 as i know of it. So know luck their.

@ZeeForge, yah, i said it only worked 50% of the time for people who use it. Not 50 percent of time i tried it. I tried it once and worked like a charm. :confused: Basicly 50% percent of people who used it, it worked, or 2 out of 4. It doesn't work for every one; that why it "50%".

Have you tried renaming db.pak to db.old, db (no .pak) db.palag or just calling it crap? Have you try deleteing it?

i have usa version, patched up. Sorry, about it not worknig but, i said it doesn't alwase work. Side affects: May not work. May cuase strange errors. None. Some have reported not working, crashing even hafe working. So duno, new system made by vryus it work for some and other it doesnt.

sorry

:(




shdaow

I don't spend enough time here

50 XP

3rd January 2007

0 Uploads

25 Posts

0 Threads

#5 11 years ago

Just remove the db.pak file and everything should work, thats what I did




shdaow

I don't spend enough time here

50 XP

3rd January 2007

0 Uploads

25 Posts

0 Threads

#6 11 years ago

Ok... so I don't know how to edit posts, but I found a great tutorial showing how to do some modelling with lightwave.

http://www.trekmania.net/art/tutorial_1.htm




admiral_Chakota

Slightly cooler than a n00b

50 XP

31st January 2007

0 Uploads

44 Posts

0 Threads

#7 11 years ago

does anyone know how to make objects tractor able such as the space stations from the odf tweak that enabled buying them and i haven't managed to contact the producer of it so im asking for any help i can get to make them movable, especialy with the sensors and turrets all being sitting ducks.




Ludwig

Music Energizes Life

50 XP

31st December 2006

0 Uploads

109 Posts

0 Threads

#8 11 years ago

Try putting a tractor beam, i think the gbeam is the right odf thingy, with a weapon hardpoint. That's how I figured out how to add a warp drive to an imported model.




admiral_Chakota

Slightly cooler than a n00b

50 XP

31st January 2007

0 Uploads

44 Posts

0 Threads

#9 11 years ago

i meant to make the stations from the mod, tractorable, A.K.A Lock on with tractor beam and drag it into a fight or into saftey if theborg over run where i am making repairs with the stations.




Guest

I didn't make it!

0 XP

 
#10 11 years ago

hi there, Im making a borg galaxyclass mod but im having some issues. My ship is showing up in legacy with all its specs, but my new textures do not. It keep using the galaxy default textures. i have followed the intructions/remark, in this thread to ensure it was looking for them but with no result.

This is what i have done so far:

1) I used a other "ship mod" to compare what files i must edit. These are the texture (dds) files, the odf file, and the m3d file (the model it self). I have named my texture file as it should (i hope) for example in textures > f_borggalaxy_A.dds f_borggalaxy_A_bump.dds f_borggalaxy_A_glow.dds etc.. etc..

until you have done all the sides, bump, glows and so on...

2a) Then i named my ship model in the M3D dir > f_borggalaxy.M3D. 2b) and made all the needed alternation in the CHUNKS dir f_borggalaxy_l_engine0.m3d etc.. etc...

3) the next step is altering the original galaxy odf to represend the BORG power :).

Then the only thing left is set the basename to basename = "f_borggalaxy" or whatever you named the MODEL name (this is what i think, the base name is..).

But as sad before, i can see the ship and play with it. It has all the extra weapons, shieling, names etc.. etc.. that's in the new ODF. But NON of my new Textures show up, it keep using the original galaxy class texture...

Im i forgeting something?? and how the does legacy stil know how to take the orignal galaxy textures, as i'm not refering to them at all, it should not even know what to do if in some case my own textures where corrupt..

can someone help me?

note: I have the added a extra file.cfg with the line "g_bGeneratePackFile = 1" in the legacy root.

I use adobe photoshop and i use the dds plug in. with the setting: DXT3 ARGB (Explicit Alpha), 2D Texture, and Generate MIP maps.