Sentinel Class -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 10 years ago

Right,

I have been working on this ship for months, and due to one reason or another i have never managed to get a final working ship, well this time i was determined.

I started from scratch using the Saucer and nacelles from Queballs Victory class.

I have made the model, i have hardpointed it, and ODFd it.

And, it wont work.

I have checked the hard points i have checked the ODF. Acid had checked the hardpoints. it wont work.

The full history is that originally i had a first draft of this ship in game, and while it was ingame i saw a few bits i dint like, things i wanted to change. so i went back, edited the model accordingly,

used the original HPs and the original ODF. the only difference is this time it wont work :/ I have re exported the model and it still doesnt work.

The game crashes when i hit the fleet assembly button which i thought was a problem with the m3d. I can for the life of me think what this problem is, can anyone help?

What am i missing? lol

Thanks!




IKS

Fuck FIFA and fuck France

32,240 XP

15th February 2006

0 Uploads

2,974 Posts

0 Threads

#2 10 years ago
Jeddy;4611612Right, I have been working on this ship for months, and due to one reason or another i have never managed to get a final working ship, well this time i was determined. I started from scratch using the Saucer and nacelles from Queballs Victory class. I have made the model, i have hardpointed it, and ODFd it. And, it wont work. I have checked the hard points i have checked the ODF. Acid had checked the hardpoints. it wont work. The full history is that originally i had a first draft of this ship in game, and while it was ingame i saw a few bits i dint like, things i wanted to change. so i went back, edited the model accordingly, used the original HPs and the original ODF. the only difference is this time it wont work :/ I have re exported the model and it still doesnt work. The game crashes when i hit the fleet assembly button which i thought was a problem with the m3d. I can for the life of me think what this problem is, can anyone help? What am i missing? lol Thanks!

Hmm, strange issue that has happened to me alot in Legacy.. Its definitely the ODF, delete the odf and your game won't crash.. There is probably a typo somewhere. When a ship crashes in game I take out the ODF and just copy/paste and rename the F_Sovereign.odf to whatever the ship is called and it will generally work on stock.




gdata

Who needs a user title?

50 XP

10th January 2007

0 Uploads

1,588 Posts

0 Threads

#3 10 years ago

Yes, IKS is right, it's most likely the odf. But you should replace the file with another one (eg. the Sovy, as Brian said) and if it still crashes then, it's the model.




Guest

I didn't make it!

0 XP

 
#4 10 years ago

Right i did like you suggested and no luck.

So its definately the model.

what kind of thing would be wrong with it?




Guest

I didn't make it!

0 XP

 
#5 10 years ago

m_nodes the m nodes should have the h_root as their parent joint




Guest

I didn't make it!

0 XP

 
#6 10 years ago

that was one of the things i changed yesterday after checking with you about where they should join.

I merged the HPs from a working ship i have in game (For my fighter mod) so its either something im adding wrong, or would it be the mesh itself?




Guest

I didn't make it!

0 XP

 
#7 10 years ago

you may have to reapply the m_nodes as they can sometime go corrupt and not work. thats happened to me before if i change its parent.




Guest

I didn't make it!

0 XP

 
#8 10 years ago

so basically delete them all and redo them? (sorry my brain is dead from DSS and CS lectures)




Guest

I didn't make it!

0 XP

 
#9 10 years ago
Jeddy;4612346so basically delete them all and redo them? (sorry my brain is dead from DSS and CS lectures)

yeah. it could also the hardpoints. make sure they all have the h_*'s and the secondary joints. make sure they all have the h_hardpoints as the parent. if its not appearing in the ship list, its the odf, so look for any spaces that shouldnt be there or any extra empty lines.




Guest

I didn't make it!

0 XP

 
#10 10 years ago

right i got it working... kind of.

Now it just flys backwards and at a 45 degree angle.

What the hell!? Its facing the right way in ms3d :S