Help with skinning -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 10 years ago

Hello guys, I'm Fiodis, head of Fiodis Fabrications. We've made some maps for other games, but not for SWBF2, so I thought we'd give it a try. It has the same general setup as some others, but there are a few unresolved problems. For one thing, I made a few skins. I edited the script by putting "dc:" in (Thanks, Lordsaber!) and it worked...halfway. The units had new skins, but not the ones I wanted. They weren't my custom skins, they were instead all white. Does anyone know how to fix that? Whoever is the most helpful will get their name written on a AT-TE. (Really!) Thanks!




theultimat

Your worst nightmare...

50 XP

13th April 2008

0 Uploads

249 Posts

0 Threads

#2 10 years ago

Right. Before I start, make sure you have the programme "Gimp". I had this problem before. Try doing the following:

  • Choose the skin you want to edit and right click on it, then click "Edit with Gimp".
  • When Gimp has loaded do what ever you want to the skin.
  • When you have finished editing the skin, merge all the layers.
  • Then press Ctrl+A (on keyboard) to select all.
  • Then press Ctrl+X. Your skin should now be white.
  • Next go to the menu Layer\New Layer. Make the layer the same size as the original skin, then click "Ok".
  • Now you need to press Ctrl+V to paste the skin.
  • Then go to Layer\Anchor Layer.
  • Then (on the main Gimp window) go to the menu File\Dialoges\Layers.
  • You should have two layers (Layer 1 + Background)
  • Right click on your background layer and click delete.
  • Then click back on the window with the skin on and go to File\Save as.
  • Leave the name the same and click save.
  • When the bow pops up, click replace.
  • Next another box should pop up called "TGA Save Options".
  • Un-select the two tick-boxes and click "Ok".
  • Then go in to your code and put a dc: in (I think you said you had already done that bit, so not much detail)
  • Next open Visual Munge and highlight your side in the Side box, then Munge away.

When you run the game, the skin should be changed to your one. If you get any errors post them here. Hope that helps. :)




caleb1117

Smilie sigs annoy me

50 XP

5th May 2006

0 Uploads

196 Posts

0 Threads

#3 10 years ago
theultimat;4329775Right. Before I start, make sure you have the programme "Gimp". I had this problem before. Try doing the following:
  • Choose the skin you want to edit and right click on it, then click "Edit with Gimp".
  • When Gimp has loaded do what ever you want to the skin.
  • When you have finished editing the skin, merge all the layers.
  • Then press Ctrl+A (on keyboard) to select all.
  • Then press Ctrl+X. Your skin should now be white.
  • Next go to the menu Layer\New Layer. Make the layer the same size as the original skin, then click "Ok".
  • Now you need to press Ctrl+V to paste the skin.
  • Then go to Layer\Anchor Layer.
  • Then (on the main Gimp window) go to the menu File\Dialoges\Layers.
  • You should have two layers (Layer 1 + Background)
  • Right click on your background layer and click delete.
  • Then click back on the window with the skin on and go to File\Save as.
  • Leave the name the same and click save.
  • When the bow pops up, click replace.
  • Next another box should pop up called "TGA Save Options".
  • Un-select the two tick-boxes and click "Ok".
  • Then go in to your code and put a dc: in (I think you said you had already done that bit, so not much detail)
  • Next open Visual Munge and highlight your side in the Side box, then Munge away.
When you run the game, the skin should be changed to your one. If you get any errors post them here. Hope that helps. :)

uh, you don't need to do anything to the texture's layers to get them to work ingame...

There are 2 typical TarGA problems, when it comes to SWBF2:

1. The TarGA MUST be saved, without RLE compression, SWBF2 won't accept it otherwise.

2. It's not sized properly, all textures must be divisible by 2.

I.E. 32x32 64x64 128x128 256x256 512x512 1024x1024 ... etc.

It's unlikely that this is the problem, if you just edited the skin, there also would have been an error in the Munge Log, if this was the case.

Also, I'd like to make you aware of a place called Gametoast. Gametoast.com • Index page

It's where alot of people go to learn modding for SWBF2, and get experienced help. Someone like you, who is already well versed in modding various games, would fit right in, and be most welcome




theultimat

Your worst nightmare...

50 XP

13th April 2008

0 Uploads

249 Posts

0 Threads

#4 10 years ago

Yeah, well spotted Caleb!:) Thanks for correcting me on that one!;)




Guest

I didn't make it!

0 XP

 
#5 10 years ago

I don't have Gimp, I've got Paint.NET....the tutorial said that would work as well....




theultimat

Your worst nightmare...

50 XP

13th April 2008

0 Uploads

249 Posts

0 Threads

#6 10 years ago

You can download Gimp for free here.