I need help with munging. -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 12 years ago

Okay, I created my map, edited some scripts and when I munge from data_ABC/_BUILD Modtools VisualMunge.exe a folder named ABC is created in the addon folder, but inside it, there is nothing except addme or something like that which is 8KB. Please help. Oh, and a weird thing is that after BF2 loads it's little bullets it crashes to the desktop, but if I delete the ABC folder, it isn't happening anymore. And yes, other custom maps made by others work. P.S. Here is what says during munging: Common\munge PC Munging addme.lua...done. Copying files to Battlefront II directory: "F:\LucasArts\Star Wars Battlefront2\GameData" Addon dir exists, continuing... Creating mod dir "ABC" dir in addon dir...done. Copying addme.script to mod dir...done Copying "mission.lvl" to modDir\data\_LVL_PC\...done Copying "core.lvl" to modDir\data\_LVL_PC\...done Copying "ABC" to modDir\data\_LVL_PC\...done Copying "SIDE" to modDir\data\_LVL_PC\...done Munge process finished Mods\BF2 was unexpected at this time.




Guest

I didn't make it!

0 XP

 
#2 12 years ago

Yeah, well... thanks a lot! :mad:




StarWarsGeek

Melancholic.

50 XP

23rd April 2006

0 Uploads

1,895 Posts

0 Threads

#3 12 years ago

woah calm down there arnt many ppl on this forunm lately u probably messed up the scripts which ones did u modify? u should only modify the gametype ones




Wraith 5

The Fun cannot be Halted!

50 XP

11th October 2005

0 Uploads

3,047 Posts

0 Threads

#4 12 years ago

Have you added water to your map, or tried to but didn't work, there is something wrong with this feature of the mod tools beta, and is a big cause of the type of crash you described.




Guest

I didn't make it!

0 XP

 
#5 12 years ago

Forget the script editing thing, I tried to make another map ( a test map ) and it still didn't work. And nothing, ABSOLUTLY NOTHING, was modified. And no, I didn't try do add water. :(




Wraith 5

The Fun cannot be Halted!

50 XP

11th October 2005

0 Uploads

3,047 Posts

0 Threads

#6 12 years ago

Hmmmm :confused: My advice would be to try www.gametoast.com , its a site dedicated to modding battlefront 2, among other star wars games. someone there should know how to fix it, or at least know what is causing the problem.




Guest

I didn't make it!

0 XP

 
#7 12 years ago

Thanks, I hope they know what's wrong!




[Y4D]R|Pvt. $ini$tar

I don't spend enough time here

50 XP

25th February 2006

0 Uploads

15 Posts

0 Threads

#8 12 years ago

lets try the obvious, did you launch Zero editor and make your map from taskbar start /program files /Lucasarts/star wars battlefront II/mod tools/star wars battlefront II mod tools ? Because thats the ONLY way it makes maps . You cannot launch the map editor to create a new world from directly in the HD loc. you have to use the taskbar in Xp to the left. Once the initial munge finishes , then you launch from within Zero Editor in you mod Id folder (ABC) and do your work (make sure you choose common layers and design) then save your work and go up to the build folder and munge from there. You will know it working because it says munge world ABC.




Guest

I didn't make it!

0 XP

 
#9 12 years ago

I did everything right except starting from STAR>PROGRAMS>LUCASART>etc. I'll try now! :)

EDIT: Oh yeah, in the command prompt (when munging) I get this error: luac returned 1