Mod compatability -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 6 years ago

Hi. I'm planning to get Battlefront 2 via Steam next week, and I was curious as to whether or not the Conversion Pack is compatible with the Dark Times II mod?




icemember

I follow teh Moo!

50 XP

16th January 2008

0 Uploads

619 Posts

0 Threads

#2 6 years ago

Probably lol. Should om Mav. He would know for sure.