not exactly understanding things -1 reply

Please wait...

GF_MaTaX

I don't spend enough time here

50 XP

29th January 2009

0 Uploads

24 Posts

0 Threads

#1 10 years ago

I'm not exactly understanding any tuts and docs about this modding stuff, I follow everything it says but it doesn't seem to be working as easily as they are explaining it.

When I create a new world and run the munge from within that new world folder, and click on munge, once it's finished it says that it should then be in my add on folder, which it is not, and that I can run the map in game, even if I copy the folder from the worlds folder over to the addon folder it still doesn't show up, I'm doing everything they say but nothing is working




Guest

I didn't make it!

0 XP

 
#2 10 years ago

Do you have Vista? If so, the folder will be located in another place. But you don't need that addon folder too much to do basic modding. Can you play the map in-game?




MileHighGuy

AKA: 5280ft HighGuy

50 XP

22nd October 2008

0 Uploads

82 Posts

0 Threads

#3 10 years ago

Ive had this problem and posted the answer in a thread on this site but it was deleted. so run to visualmunge.exe go to set bf2 directory(top of window) browse to your addon folder there you should see the 3 letter map id of your map delete it go to recycle bin find your map restore it




GF_MaTaX

I don't spend enough time here

50 XP

29th January 2009

0 Uploads

24 Posts

0 Threads

#4 10 years ago

ok well I just realised if I don't run it in admin mode they come up ingame and I can play them, but because of some probs with game I need to run in admin mode, also, what you said to delete it and restore it, restore it to where?




Guest

I didn't make it!

0 XP

 
#5 10 years ago

Just right-click and select "restore". It will magically teleport the file back whence it came.




GF_MaTaX

I don't spend enough time here

50 XP

29th January 2009

0 Uploads

24 Posts

0 Threads

#6 10 years ago

ok I see, I think I may have done something wrong in the whole proccess so I'm gonna start over, also, when I try to run the BF2_modtools from inside the BF2_Modtools folder, it says error occured while trying to run, blah blah blah, blinkw32,dll was not found, whats that mean and why was it not found?




Guest

I didn't make it!

0 XP

 
#7 10 years ago

That BF2_Modtools is not Visual Munge. If your map is crashing, move that BF2Modtools.exe into your SWBF2/Gamedata folder and run it from in there, then play your map. Afterwards, in the Gamedata directory, there will be a BFlog.txt telling you exactly what is wrong. Search for "Mod tools" to find the Visual Munge. It can also be found inside Data***/_BUILD where *** is your three letter map name. This is all covered in the shipped documentations....:rolleyes:




GF_MaTaX

I don't spend enough time here

50 XP

29th January 2009

0 Uploads

24 Posts

0 Threads

#8 10 years ago

ok heres my next Q, when I got to edit some tga's it's just this blank looking file, like it looks like some type of overlay, like the SBD's, is just this airbrush looking spray on a transparent BG, theres no droid there for me to edit, why aren't they showing up and how can I fix this?




MileHighGuy

AKA: 5280ft HighGuy

50 XP

22nd October 2008

0 Uploads

82 Posts

0 Threads

#9 10 years ago

theres a better video tut on gametoast, but heres a short one: that is the skins alpha channel to get rid of it do this: 1.right click the background 2.select add layer mask 3.in the popup select transfer layers alpha channel and ok 4.right click it again and select delete layer mask 5.you should now see the skin and are free to edit (this may result in somme units being overly shiny,gametoast tut will not have this result)




Guest

I didn't make it!

0 XP

 
#10 10 years ago

It is only shiny because you fail to replace the original alpha channel. If you do not want a shiny skin then, once you have finished editing it, go to the original unedited image and click colors/components/decompose, select RGBA mode and uncheck "decompose to layers". Once you've did that, you should get four separate images. Close them all except the alpha one. Then, go to your edited image and click colors/components/decompose and select RGB mode (not RGBA this time) and again uncheck "decompose to layers". You will get three popup images. Don't close any. Now, go into one of the four seperate popup images you got. Doesn't matter which one. Go to colors/components/compose. Select RGBA mode. For red, select the popup image with "red" in it's name. Same for blue and green. For "alpha" select the image that you got from the original, unedited skin, with "alpha" in it's name. Click compose. There. You will get a new image that comes complete with an alpha channel. Now, in-game, your unit should not be shiny. Note that this tutorial was typed up for GIMP, not Paint.NET. I find that GIMP is a lot easier to use for alpha channel work than Paint.NET, because GIMP has the images pop up in seperate boxes. So I would recommend doing droid, alliance, and imperial skins in GIMP rather than Paint.NET.