"dc:" does not work in scripts -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 8 years ago

Hi all Why is it that when i make a really good skin or something and then put "dc:" into a script battlefront 2 cuts me off? cheers




verncoleman

I'm too cool to Post

50 XP

16th November 2010

0 Uploads

17 Posts

0 Threads

#2 8 years ago

You have to put it in perfectly or it wont work, and a lot of posts I've seen on this topic aren't very specific, or post it wrong.

Here is an exact copy from my working lua. file @ data_BBB/common/scripts/BBB/BBBc_con.lua :

ReadDataFile("sound\\yav.lvl;yav1cw") ReadDataFile("dc:SIDE\\rep.lvl", "rep_inf_ep3_rifleman", "rep_inf_ep3_rocketeer", "rep_inf_ep3_engineer", "rep_inf_ep3_sniper", "rep_inf_ep3_officer", "rep_inf_ep3_jettrooper", "rep_hover_fightertank", "rep_hero_anakin", "rep_hover_barcspeeder") ReadDataFile("SIDE\\cis.lvl", "cis_inf_rifleman", "cis_inf_rocketeer", "cis_inf_engineer", "cis_inf_sniper", "cis_inf_officer", "cis_inf_droideka", "cis_hero_darthmaul", "cis_hover_aat") ReadDataFile("SIDE\\tur.lvl", "tur_bldg_laser", "tur_bldg_tower") SetupTeams{ rep = { team = REP, units = 20, reinforcements = 150, soldier = { "rep_inf_ep3_rifleman",9, 25}, assault = { "rep_inf_ep3_rocketeer",1, 4}, engineer = { "rep_inf_ep3_engineer",1, 4}, sniper = { "rep_inf_ep3_sniper",1, 4}, officer = {"rep_inf_ep3_officer",1, 4}, special = { "rep_inf_ep3_jettrooper",1, 4}, }, cis = { team = CIS, units = 20, reinforcements = 150, soldier = { "cis_inf_rifleman",9, 25}, assault = { "cis_inf_rocketeer",1, 4}, engineer = { "cis_inf_engineer",1, 4}, sniper = { "cis_inf_sniper",1, 4}, officer = {"cis_inf_officer",1, 4}, special = { "cis_inf_droideka",1, 4}, } } Hope this helps. P.S. If you ever try to add another unit to your side, you must add the name to the list where you put dc:, AND the list where you can change the setup teams.




Guest

I didn't make it!

0 XP

 
#3 8 years ago

thankyou I understand now cheers:D:beer:




Guest

I didn't make it!

0 XP

 
#4 8 years ago
Unit_672;5430189thankyou I understand now cheers:D:beer:

Although i just tried it again and it still doesn't work, still cuts the entire program off and has no "FATAL" error message.:mad:




verncoleman

I'm too cool to Post

50 XP

16th November 2010

0 Uploads

17 Posts

0 Threads

#5 8 years ago

That was a fully functioning script. And I've don the exact same thing a hundred times. The problem may lie elsewhere.

To make sure, make a brand new world and ad the dc: to the .lua, and put your chosen side and side common folder in the maps side folder(absolutely necessary) and munge.

But change nothing else. If it crashes after you add the dc:, but not before then I have no idea whats wrong(if you DONT get a mung error saying bla bla bla expecting bracket but none found, the .lua is working perfectly).

If the game does work though double check you didn't make some easy mistakes like these:

Check to make sure you've installed the 1.1 and 1.3 patches, and double check your skins format (this is very easy to get wrong). I use battlefront viewer v0.03 to convert the mesh and its skins to .png and convert it back, to ensure it gets done properly. (WARNING, do not use msh. charicter files converted with bfviewer only the skins!)

Make sure you have both the correct side folder AND the side common folder in your maps side folder. If you edited the .odf files double check them. And if all else fails, double check everything. Well that's all I can think of, hope it helps, Vern




Guest

I didn't make it!

0 XP

 
#6 8 years ago
Make sure you have both the correct side folder AND the side common folder in your maps side folder. If you edited the .odf files double check them. And if all else fails, double check everything.

verncoleman you are a GENIUS. thankyou for helping with that. :)




verncoleman

I'm too cool to Post

50 XP

16th November 2010

0 Uploads

17 Posts

0 Threads

#7 8 years ago

No problem buddy, to quote Red Green "were all in this together".