Where's the shadow ? : Resolved -1 reply

Please wait...

Musart

I'm too cool to Post

50 XP

6th March 2006

0 Uploads

13 Posts

0 Threads

#1 12 years ago

Hi to all, I want to share this. I had this problem : No shadow were present on the map even if i put lights with cast shadow ON. It seems that newly made maps had this problem, (No shadow from object and soldiers, etc...) Here's what i found : There are many layers in a map (Conquest, CTF-1, CTF-2, Hunt, etc...). The zero editor put lights informations in files called : whatever_map_name.LGT and / or whatever_map_name_conquest.LGT depending on the layer you choose and so on. To have shadows working on the map you have to do this : 1- make sure that the BASE layer is the ON 2- add a light (DIRectionnal is working best), rename it to anyname, check CAST SHADOW and do all the other setting you want (Position, direction, color, etc...) 3- In the Global Light box enter the name of the light you've just created 4- Save, munge and enjoy. What you did in this procedure is : This ensure that the Light settings and Global light settings are in the same layers, so they are in the same file. If they are not in the same file this won't work. If you open the whatever_map_name.LGT file with a text editor you will see the settings of the newly created light BEFORE (very important) the global light settings. Also, if you want objects cast shadow, see Appendix B - Shadowvolumes in the art guide.doc. I hope this is clear and helped someone. MUS




Guest

I didn't make it!

0 XP

 
#2 12 years ago

great work, man :) now the visual quality of the maps will increase i cant wait to see your maps:bows: keep up the good work !!! ice599