Annoying Sound Glitch -1 reply

Please wait...

Srenn Orj

Slightly sane

50 XP

13th June 2007

0 Uploads

76 Posts

0 Threads

#1 10 years ago

In singleplayer, whenever I attack, the sound of the weapon firing or lightsaber swinging is delayed by a little under a second. This is with every single weapon. All the other sound effects work properly. I have not tried multiplayer. I have fully reinstalled the game twice, to no avail. I'm using Windows XP with Realtek High Definition Audio. Anything I can try?




Guest

I didn't make it!

0 XP

 
#2 10 years ago

Have you tried updating your sound drivers? Here, try these:

Download Realtek High Definition Audio Driver, Realtek High Definition Audio Driver 2.08 Download

You can also run DirectX Diagnostic Tool by going to Start -> Run and typing DxDiag. When the application fully loads, go to Sound tab and change Sound Hardware Acceleration Level to some lower value and see if it makes any difference in the game. Try all values and test the game each time.




Corona Six

The Internet ends at GF

50 XP

6th September 2008

0 Uploads

105 Posts

0 Threads

#3 10 years ago

I have Realtek too, but I don't get this problem. It's not too bad of a problem anyway, sounds delayed in "a little under a second," is not that big of a deal.

If its lagging, make sure you don't have programs/processes that hog memory.

EDIT: lol, Tricorder beat me to it.




Srenn Orj

Slightly sane

50 XP

13th June 2007

0 Uploads

76 Posts

0 Threads

#4 10 years ago

Turning the hardware acceleration up fixed it. Thanks.




Guest

I didn't make it!

0 XP

 
#5 10 years ago

You're welcome. I thought your acceleration level is already up at maximum since it's a default setting. I guess you lowered it for some reason and forgot about it. Just for the future reference (in case someone else comes here with the same problem), checking Sound Hardware Acceleration Level is one of the first things to do in cases like this.