Frame Rate/Loading Issue -1 reply

  • 1
  • 2

Please wait...

Schofield VIP Member

om :A

319,570 XP

24th October 2007

1 Uploads

30,540 Posts

0 Threads

#1 8 years ago

Whenever I launch the game, the framerate is horrible, I can move around the main menu, but slowly. Oh, and the maps do not load.




Guest

I didn't make it!

0 XP

 
#2 8 years ago

Full computer specifications required.

  • CPU
  • RAM amount
  • Graphic card + currently installed driver version
  • Operating system
  • Currently installed DirectX version
  • Is it a desktop computer or a laptop



Schofield VIP Member

om :A

319,570 XP

24th October 2007

1 Uploads

30,540 Posts

0 Threads

#3 8 years ago

Tricorder;5419546Full computer specifications required.

  • CPU
  • RAM amount
  • Graphic card + currently installed driver version
  • Operating system
  • Currently installed DirectX version
  • Is it a desktop computer or a laptop

Forgot to post those...

CPU - Intel Core 2 Quad CPU Q9550 @ 2.83GHz

RAM - 4096MB

OS - Windows 7 Home Premium 32-bit (6.1, Build 7600)

Graphics Card - Nvidia GeForce GTX 285 + Driver Version 8.17.12.5896

DirectX - 11

Desktop




Guest

I didn't make it!

0 XP

 
#4 8 years ago

There are several things you can try.

For start, right-click on the executable file responsible for launching the game, select Properties and go to Compatibility tab. Now, enable compatibility mode and set it for Windows XP, disable Desktop Composition, enable administrative privilege level, click OK, run the game directly from the executable file (don't use the launcher) and see if anything changed.




Schofield VIP Member

om :A

319,570 XP

24th October 2007

1 Uploads

30,540 Posts

0 Threads

#5 8 years ago

That didn't seem to do anything.:( However, when I didn't use the launcher, it lagged a lot. I went back and tried it with the launcher and the lag wasn't as bad, but the maps still wouldn't load.




Guest

I didn't make it!

0 XP

 
#6 8 years ago

Ok, let's try something else.

  • go to the Control Panel
  • double click Sound to open it
  • go to the Recording tab (second one over)
  • right click in any open area within the tab
  • select Show Disabled Devices
  • select Stereo Mix and turn it on

This usually solves similar problem with BF2 on Vista, so it might work on Windows 7 too, assuming the instructions above can be applied in Windows 7. Give it a try.




Schofield VIP Member

om :A

319,570 XP

24th October 2007

1 Uploads

30,540 Posts

0 Threads

#7 8 years ago

Stereo Mix doesn't appear when I show disabled devices.:uhm:




Guest

I didn't make it!

0 XP

 
#8 8 years ago

I guess it's not the same in Windows 7 as it is in Vista. Ok, let's move on.

Find the executable file responsible for bringing up the launcher, set compatibility mode for Windows XP on it as well, run the game with the launcher and see what happens.




Schofield VIP Member

om :A

319,570 XP

24th October 2007

1 Uploads

30,540 Posts

0 Threads

#9 8 years ago

Cool, ok so the framerate issue doesn't seem to be a problem anymore. The maps still don't load, a black screen for about 30 seconds, and then it shows the loading screen - but never stops.




Guest

I didn't make it!

0 XP

 
#10 8 years ago

Where did you install the game to? Program Files folder or outside of it?




  • 1
  • 2