Adding new Infantry -1 reply

  • 1
  • 2

Please wait...

Guest

I didn't make it!

0 XP

 
#1 11 years ago

Hello all, I am new to posing in the Forum, though I have followed it for many months. I have become fairly proficient at Modding EAW, but I have recently become stuck on trying to add infantry. While I have been very sucessfull at implimenting and coding space vehicles, the use of the RSkin FXOs eludes me. I have new infantry models finished, skinned, and animated, but I am unable to get them ingame. I am currently useing 3ds Max 8 and have the fixes for the Rskin shaders that allow the models to be seen the the viewport. It is entirely possible that I am rigging the new models wrong in max. I am using the Skin Modifier to attach the mesh to the bones, and in max everything seems to be in order. When I export to .ALO I don't get any "Bone Mappigs". Can anyone tell me what I am doing wrong? Under the Model Properties in the .ALO viewer the Mesh Data shows: AlD3dVertN instead of AlD3dVerRskinNU2. The mesh also does not show up in the .ALO viewer. The bones are there, and the animations seem to work with them, but NO MESH! I know that it is possible to get this to work, as others have added new units. If anyone could shed some light on this, you would be saving someone a great deal of stress. It kills me that I cannot figure this out on my own. Thanks to anyone willing to help.




1upD

Dread pwns me!

50 XP

15th January 2007

0 Uploads

462 Posts

0 Threads

#2 11 years ago

What infantry are you adding? [COLOR=white](please don't say clonetrooper, please don't say clonetrooper)[/COLOR]




The_Sith_Lord

Supreme Emperor of the Galaxy

50 XP

24th May 2006

0 Uploads

1,095 Posts

0 Threads

#3 11 years ago

I like clones!




Guest

I didn't make it!

0 XP

 
#4 11 years ago

Well, I don't want to give to many details, but it would be several different types. Ever since the game engine came out, I have been working with a couple of friends to make our own version of the game. I am a huge Sci-Fi fan and wanted a game which offered the ability to use ships and units from many different origins. We have added in many ships (only buildable on certain planets to keep it managable) including death clones etc. Some of the ships were created in 3ds max while others I had to ask permission to use. Now we are trying to create some ground units to go along with the rest of the game. I just need help with the Rskin issue. (If that is even the true root of the problem) Maybe if I can get them working well we will release them. I wouldn't want to release any junk into the community.




1upD

Dread pwns me!

50 XP

15th January 2007

0 Uploads

462 Posts

0 Threads

#5 11 years ago
The_Sith_Lord;3510366I like clones!

I LOVE clones, but if he modelled them, I'd have to scrap all my precious skins and either lose to him or just reskin his(I've practically memorized the stormtrooper skin) Once you fix your model, any chance you could apply my Clone Trooper skin around a new model?




Sidious Invader

Dark Lord Of The Sith

50 XP

9th January 2007

0 Uploads

853 Posts

0 Threads

#6 11 years ago

I am not very experienced with modelling, but did you UVunwrap it? It might be that, models have to be UV'd to work in game.




Vaders_legion

NO U

50 XP

17th December 2005

0 Uploads

1,006 Posts

0 Threads

#7 11 years ago

wait a sec, i thought infantry were only doable in max 6 and only worked ingame if u modeled it with max 6




Guest

I didn't make it!

0 XP

 
#8 11 years ago

Thanks for the replies. I guess the best way to get help is to break things down. I currently have models finished in editable mesh form. The skeletons are done with bones vs. createing a biped which may be the problem. Post creating skeletons I used the skin modifier to apply the DDS skins via a Rskin shader. When I export into alamo format only the bones seem to make it. If I use a meshgloss or other standard shader, the mesh shows up fine but is not bound to the bones. Clearly I am missing whatever step is required to make the Alamo exporter maintain the skin attachment to the bones. The models are rigged for creating animations in Max, but upon export zap...No mesh! If someone knows how to get the mesh attached to the bones in alamo format I would be eternally gratefull. I figure there must be some fundamental step in max that I am missing since in the Alamo viewer the mesh names show up with Rskin shaders, but no bone attachments and the Mesh isn't visisble. Soooooo frustrating, but it will be worth it in the end to see my models in game. If anyone needs amplifying details, ask questions and I will be more than happy to answer.




Sgt. Hicks

AlphaBlue Modding Council

50 XP

18th July 2006

0 Uploads

289 Posts

0 Threads

#9 11 years ago

Infantry can be done with max8 because I am working with infantry, you can export and test no problem. I'm not sure how you are rigging but my guess would be check to see what you are applying the material to. If you can tell me more I might be able to help more.




Guest

I didn't make it!

0 XP

 
#10 11 years ago

One more quick thought. I make use of alamo proxies quite a bit when modeling ships/death clones. Do I need to be useing them in my infantry models?




  • 1
  • 2