Colliision mesh problem...... -1 reply

Please wait...

Alebalelec

Slightly cooler than a n00b

50 XP

17th April 2006

0 Uploads

51 Posts

0 Threads

#1 10 years ago

I've been making a model, its skinned and i must admist looks good. Problem is that i'm having trouble with the collision mesh. Ive followed a couple of tutorials but where i fall short is that i cannot find "directx 9" in the matierals list. So cannot give it the collisionmesh.fx I'm using 3ds max 8 with sp 3 and dx 9. Can any one help me out? Much thanks. Aleba EDIT: The shader appears if i click the tab for incompatible. but is grayed out and unuseable.




Sidious Invader

Dark Lord Of The Sith

50 XP

8th January 2007

0 Uploads

853 Posts

0 Threads

#2 10 years ago

In the material editor, select the "standard" button, then select directx shader. Then select your shader, meshcollision.fx. In the utilities menu(hammer), select more, load alamo tools, and with the collision mesh selected check the "enable collision" box.




Alebalelec

Slightly cooler than a n00b

50 XP

17th April 2006

0 Uploads

51 Posts

0 Threads

#3 10 years ago

yes, i read that in a tut. HOWEVER- The direct x shader is not in the list unless I click to show the incompatible ones. and then it does nothing. because its incompatible. image1yu0.th.jpg




Sidious Invader

Dark Lord Of The Sith

50 XP

8th January 2007

0 Uploads

853 Posts

0 Threads

#4 10 years ago

Yeah, Ok I know what's wrong, but how to explain it. Access 3ds max 8 thru your start menu, in the 3dsmax folder there is change graphics mode, make sure it's directx 9.0.




Alebalelec

Slightly cooler than a n00b

50 XP

17th April 2006

0 Uploads

51 Posts

0 Threads

#5 10 years ago

ok gonna test it but that makes sence - thanks! Btw howcome my newer versions of the model dont show up in alo view. only there bones.




Sidious Invader

Dark Lord Of The Sith

50 XP

8th January 2007

0 Uploads

853 Posts

0 Threads

#6 10 years ago

Because your not in directx 3ds mode, the shaders are invalid.




Alebalelec

Slightly cooler than a n00b

50 XP

17th April 2006

0 Uploads

51 Posts

0 Threads

#7 10 years ago

BWUHAHAHAHA Thank you!!!!




Sidious Invader

Dark Lord Of The Sith

50 XP

8th January 2007

0 Uploads

853 Posts

0 Threads

#8 10 years ago

If you cannot see your model after a shader is applied go to your material editor, then options, then "force software rendering" checkbox.




Alebalelec

Slightly cooler than a n00b

50 XP

17th April 2006

0 Uploads

51 Posts

0 Threads

#9 10 years ago

ok, thank you very much the collsion box is working now, HOWEVER, the model itself is still not showing up in the ALO viewer. the bones are though. and the collsion box does when i click on it in the options box. even after i followed your force software rendering advice. I appreciate you helping me with this, and i'd be happy to show you the finnsihed results - if you can keep them secret... =p




Alebalelec

Slightly cooler than a n00b

50 XP

17th April 2006

0 Uploads

51 Posts

0 Threads

#10 10 years ago

intercepterbonesly4.th.jpg interceptercollisionbk4.th.jpg missingsu9.th.jpg Whatever the problem is that should be the last thing to sort out before i slip it ingame. ( hopefully)