MonCalamari MC 40 -1 reply

  • 1
  • 2

Please wait...

Guest

I didn't make it!

0 XP

 
#1 8 years ago

I'm trying to install an MC 40 into my game using one of your guides, but it is launching vannilla FOC. Can you help????




Guest

I didn't make it!

0 XP

 
#2 8 years ago

You need a folder structure like this: Mod_Name/Data/ (The mod name CANNOT have spaces in it otherwise it won't work) Create a folder in 'Data' called 'XML'. Into the 'XML' folder, you put the XML files you modified/created.

Create a folder in 'Data' called 'Art', and in this folder create two more - 'Models' and 'Textures' (take a wild guess as to what goes in these) Create a folder in 'Data' called 'Text', in here you put your modified Mastertext file. Now you need to put the folder 'Mod_Name' into your 'Mods' folder. (If the 'Mods' folder doesnt exist, create it) If your modding the FOC expansion: 'Star Wars Empire at War Forces of Corruption\Mods' If your modding the original EAW: 'Star Wars Empire at War \GameData\Mods' (I think - I've never done one for the original EAW) Finally, you can either: create a shortcut (Complicated) or download the Mod launcher (Easy) http:// empireatwar.filefront.com/ fil...cher_Zip;96444 Some people have had trouble with the mod launcher not working. If this is the case with you, I'll try and show you how to do Modpaths or .bat files.




Guest

I didn't make it!

0 XP

 
#3 8 years ago

I have the structure already, i'm just wondering if the XML coding has gone kapput. all help grateful.




Guest

I didn't make it!

0 XP

 
#4 8 years ago

I've had to do all the XML's from scratch, can some one check them for me and tell me where I've gone wrong




Guest

I didn't make it!

0 XP

 
#5 8 years ago

Its probably not a mistake in your XMLs, otherwise the game would just crash at the splash screen.

Did you add your XMLs to the 'Gameobjectfiles' XML?




Guest

I didn't make it!

0 XP

 
#6 8 years ago

yep, all files input as per Lord X's guide. really stumped.




Guest

I didn't make it!

0 XP

 
#7 8 years ago

Then I can't think of anything else that would be wrong. If I do I'll let you know, sorry I couldn't be of more help.




Guest

I didn't make it!

0 XP

 
#8 8 years ago

ok, may have to start from scratch, unless someone can look over my xml's




Guest

I didn't make it!

0 XP

 
#9 8 years ago

This is my hardpoint xml

<?xml version="1.0"?>

HARD_POINT_ENGINE Yes Yes TEXT_ENGINE_HARDPOINT 500.0

Large_Explosion_Space Unit_Hardpoint_Engines_D eath

rv_moncal_mc40_HP_E.alo HP_E_Bone HP_E_Bone HP_E_EMITDAMAGE HP_E_MAINENGINES

HARD_POINT_FIGHTER_BAY Yes Yes TEXT_FIGHTER_BAY_HARDPOINT yes yes 500.0

Large_Explosion_Space Unit_Hardpoint_Bay_Death

SPAWN_00 SPAWN_00

HARD_POINT_WEAPON_LASER Yes Yes TEXT_WEAPON_LASERCANNON 500.0

rv_moncal_mc40_HP_F-C.alo HP_F-C_Bone HP_F-C_Bone HP_F-C_blast HP_F-C_EmitDamage

Large_Explosion_Space Unit_Hardpoint_Bay_Death

Damage_Star_Destroyer FP_F-C_00 FP_F-C_01 90.0 90.0 Proj_Ship_Medium_Laser_Canno n_Red 2.0 3.0 5 0.2 800.0 Unit_Rebel_Ship_Laser_Fire

Fighter, 6.0 Bomber, 5.5 Transport, 1.0 Corvette, 12.0 Frigate, 70.0 Capital, 30.0 Super, 30.0 No

HARD_POINT_WEAPON_LASER Yes Yes TEXT_WEAPON_HEAVY_TURBO 500.0

rv_moncal_mc40_HP_M-R.alo HP_M-R_Bone HP_M-R_Bone HP_M-R_blast HP_M-R_EmitDamage

Large_Explosion_Space Unit_Hardpoint_Bay_Death

Damage_Star_Destroyer FP_M-R_00 FP_M-R_01 130.0 130.0 Proj_Ship_Turbolaser_Red 2.0 3.0 4 0.2 1500.0 Unit_Rebel_Ship_Laser_Fire

Fighter, 70.0 Bomber, 70.0 Transport, 50.0 Corvette, 25.0 Frigate, 15.0 Capital, 10.0 Super, 30.0 No

HARD_POINT_WEAPON_LASER Yes Yes TEXT_WEAPON_HEAVY_TURBO 500.0

rv_moncal_mc40_HP_M-L.alo HP_M-L_Bone HP_M-L_Bone HP_M-L_blast HP_M-L_EmitDamage

Large_Explosion_Space Unit_Hardpoint_Bay_Death

Damage_Star_Destroyer FP_M-L_00 FP_M-L_01 130.0 130.0 Proj_Ship_Turbolaser_Red 2.0 3.0 4 0.2 1500.0 Unit_Rebel_Ship_Laser_Fire

Fighter, 70.0 Bomber, 70.0 Transport, 50.0 Corvette, 25.0 Frigate, 15.0 Capital, 10.0 Super, 30.0 No

HARD_POINT_WEAPON_LASER Yes Yes TEXT_WEAPON_LASERCANNON 125.0

Large_Explosion_Space_Empire Unit_Hardpoint_Torpedo_D eath

rv_moncal_mc40_HP_B-C.ALO HP_B-C_Bone HP_B-C_COLL HP_B-C_BLAST HP_B-C_EMITDAMAGE

FP_B-C_00 FP_B-C_01 130.0 130.0 Proj_Ship_Large_Laser_Cannon _Green 2.0 2.0 15 0.2 1400.0 Unit_Rebel_Ship_Laser_Fire

Fighter, 5.0 Bomber, 5.0 Transport, 5.0 Corvette, 10.0 Frigate, 10.0 Capital, 10.0 Super, 8.0

Did i miss something?




Blood Asp

Modding, Coding, Pwning

50 XP

9th November 2010

0 Uploads

503 Posts

0 Threads

#10 8 years ago

Do you have a separate hardpoint file for it (the code above seems that is the case)? And what all problems are you having with it?

EDIT - if it's the hardpoints you're having a problem with, make sure you put your hardpoint xml as an entry into this: Hardpointdatafiles.xml - for some reason they don't show up if you don't...




  • 1
  • 2