replacing models -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 12 years ago

I am trying to replace Piett's executor with a new model, but am getting an exception when I run the program. I have added all the hardpoints that are needed and reassigned the bones to the new model. ex.: LeftSideHP05 LeftSideHP05 HP_B-R_Blast HP_B-R_EmitDamage (I kept the rest of each hard point the same)

Questions: What are the and tags? Where could I find this 'HP_B-R_Blast' thing? (its not in particles.xml) Would I have to switch that to something else too?

Question: I just kept the collision_mesh the same as the attachment_bone. Was I suppose to do that?

I also went the piett part of the xmls and switched the model and death clone out, then updated the list of hardpoints in the piett section.

What am I forgetting to do? (this is all within aotr)




Guest

I didn't make it!

0 XP

 
#2 12 years ago

It is evilljedi's model SSD.alo Is the collision_mesh even needed? could that be the problem? I mean, the hard points aren't objects in the alo viewer (in the left pane), but they were for the previous model. For ssd.alo, the collision objects appear to be box01, box02, and box03. do I assign the hardpoint bones to the appropriate collision boxes in this case or what?

Someone please say something! I kinda need help.. (NOTE: I was not able to simply edit this into my first post)




Soveriegn

My EMPIRE!!

50 XP

14th October 2007

0 Uploads

307 Posts

0 Threads

#3 12 years ago

Well if you have FOC I think you should use the executer, but if you don't just replace anything that has to do with piett's model and replace it with the SSD model. It worked for me one time.




Guest

I didn't make it!

0 XP

 
#4 12 years ago

It is FoC, and a mod. but the model in the mod is the wrong proportion, way too wide. its also overpowered and so on. So I wanted to replace it with evilljedi's release of the ssd.

I ask if I missed anything when I was modifying the xmls. I also ask if I messed up the collision meshes and would that be a huge problem?




Darth_Windu

RotC Creator

50 XP

3rd September 2007

0 Uploads

1,194 Posts

0 Threads

#5 12 years ago

Did you remember to change the model name in the Executor's XML?




Guest

I didn't make it!

0 XP

 
#6 12 years ago

yes I did. I made changes to units_space_empire_executor.xml, units_hero_empire_aotr_captain_piett.xml, and hardpoints_empire.xml. I' guessing its something with the hardpoints one, since that is where the biggest changes were made and all. Could it still be the collision meshes?