Turning the Alliance Shuttle into an Imperial ground transport -1 reply

Please wait...

xanofar

Back from the dead!

50 XP

15th April 2008

0 Uploads

783 Posts

0 Threads

#1 10 years ago

Well, as the title suggests, I'm trying to make the Republic Transport seen in the game Clone Wars which is the exact same thing as the Rebel Hero Shuttle in EAW, so I figured this would be easy, but I'm encountering these problems: While I succeeded in getting infantry in, it sometimes fails, and I can't get them out. Though I've given it the projectile type, rate, etc. (and added it to behavior), it won't shoot. It stays underground, despite me raising the hover offset.

Help/tips?

If I had to guess, I'd say the problem is within this text, though I don't know what the problem is, exactly:

(Name, text ID, .tga file, etc.)

2933.0fRV_HEROTRANSPORT.ALO1.01.5YesEmpire2.0 2.3 3.0 Armor_Transport Shield_Tank7063003758999999 SELECTABLE AFFECTED_BY_SHIELD, ABILITY_COUNTDOWN, WALK_LOCOMOTOR,

SHIELDED, WEAPON, POWERED, REVEAL, HIDE_WHEN_FOGGED, UNIT_AI, SURFACE_FX,

TELEKINESIS_TARGET, STUNNABLE, Targetting, WIND_DISTURBANCE, DAMAGE_TRACKING,

GARRISON_VEHICLE, SQUASH Infantry, Vehicle 80090Yes Yes

HoverNo220.013.01, 0.66, 0.330, 1, 2null,SFX_Grenade_Detonation,

SFX_Grenade_DetonationLarge_Explosion_LandYesYestrue50100.4Shield_Penetration_Effect_Particlenetration_Particle>

Proj_Ship_Small_Laser_Cannon_Red3.040.2200.0 Infantry, 10.0

Vehicle, 7.5 Structure, 5.0

Air, 55.0

(sfx, etc)

9931265.0, 50.0Generic_Shadow Vehicle CanContainGarrison Hover1x1yes50.0 Yes Yes125.038.0Yes6

(the rest is largely stuff I didn't mess with or is stuff I'm 99% sure isn't the problem)

Thanks.




Darth_Windu

RotC Creator

50 XP

3rd September 2007

0 Uploads

1,194 Posts

0 Threads

#2 10 years ago

There's no garrison bone name. Basically what this means is the game has no information on where the units are going to come out, therefore they can't come out.

I'd suggest using 'Root' as the bone name, and increasing the garrison enter and exit distance to about 10.




T3h Piti

Where is this.

50 XP

9th March 2007

0 Uploads

3,087 Posts

0 Threads

#3 10 years ago

also does it have firing bones so it can actually shoot. i've never checked it in the .alo viewer




Darth_Windu

RotC Creator

50 XP

3rd September 2007

0 Uploads

1,194 Posts

0 Threads

#4 10 years ago

Yeah it does, it has to as it fires (albeit slowly) as a normal space transport.




T3h Piti

Where is this.

50 XP

9th March 2007

0 Uploads

3,087 Posts

0 Threads

#5 10 years ago

ah yes, true, very true.




Spartan-517

The Arbiter of Insanity

50 XP

11th October 2006

0 Uploads

121 Posts

0 Threads

#6 10 years ago

try adding 80.0 to adjust how high it flies, I found this line of code in the data for the lancet. It as worked for me.




Vaders_legion

NO U

50 XP

17th December 2005

0 Uploads

1,006 Posts

0 Threads

#7 10 years ago

That line of code is somewhat glitchy, it doesnt allow melee units to attack the unit using that line of code.




xanofar

Back from the dead!

50 XP

15th April 2008

0 Uploads

783 Posts

0 Threads

#8 10 years ago
Spartan-517;4395287try adding 80.0 to adjust how high it flies, I found this line of code in the data for the lancet. It as worked for me.

Yeah, I had already set it from 50 to 100, with no difference in results whatsoever. But yeah, it's worked for other space models I've tried this with in the past, so yeah. "50.0" was the hover offset height for the alliance shuttle landing, by the way, so that height should've worked perfectly, but I guess it's just not willing to work.

Anyway. I've tried all sorts of crap, and it still doesn't fire (odd, though, I imagine I *could* fix this problem with time, it's not worth it if it still stays underground and won't let units out).

But yeah, it now lets units in successfully almost every time, but still won't let anything out. I give up. Strange.

Anybody know if somebody's made a mod with these working or an alternate model that will work? (unlikely, but yeah)




Darth_Windu

RotC Creator

50 XP

3rd September 2007

0 Uploads

1,194 Posts

0 Threads

#9 10 years ago

Did you make the code changes I suggested?




xanofar

Back from the dead!

50 XP

15th April 2008

0 Uploads

783 Posts

0 Threads

#10 10 years ago
Darth_Windu;4395602Did you make the code changes I suggested?

Yeah, entering worked a little more smoothly, but it still wouldn't allow any exiting.

I tried a couple other tweakings after that as well, and still no luck.

It's a shame, really. Would've made a nice alternative to the Juggernaut as a non-frontline assault transport.