Turret problem -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 11 years ago

hello everyone im having serious problems with one of my models.....it has a turret at the top which i am coding in as a untargetable hardpoint.....the turret shows up in game but refuses to fire or rotate in any directions (including up/down)....im 100% sure that the problem is with the turret rig, not my coding.... i have uploaded the turret file.........can any expert modeler/modder take a look at it and tell me whats wrong with it and wat needs to be fixed?? thank you in advance




Chandler

Phoenix Rising Mod Leader

50 XP

22nd March 2003

0 Uploads

267 Posts

0 Threads

#2 11 years ago

I had that issue too and I'm pretty sure it does have to do with your coding. Make sure you add 1.0 to the turret hardpoint (it cannot have zero health for whatever reason).




Sidious Invader

Dark Lord Of The Sith

50 XP

9th January 2007

0 Uploads

853 Posts

0 Threads

#3 11 years ago

Your model actually looks fine with the exception of where you placed your fire bone. I think it's in the coding, can you post it here...and take a look at this tutorial..... Tutorial: Multiple Moving Turrets - Petroglyph Forums




Guest

I didn't make it!

0 XP

 
#4 11 years ago

umm thanks a lot guys...............it WAS a problem in the coding i didnt put any health in it...........ya now it works




Guest

I didn't make it!

0 XP

 
#5 11 years ago

dammit...this is like jumping from the firepan staright into the fire.....................how do i get these turrets to fire independently??.....they only fire when ordered to fire....i have already put the fire when idle and the fire when targeting tag in the hardpoints...... any ideas??




Chandler

Phoenix Rising Mod Leader

50 XP

22nd March 2003

0 Uploads

267 Posts

0 Threads

#6 11 years ago

Put the Gargantuan's LUA script on the unit.




Guest

I didn't make it!

0 XP

 
#7 11 years ago

u mean the Objectscript_gargantuan file??............how is that gonna help?? that file only tells the gargantuan to use the shield flare when there are specific number of units around if there is certain amount of shieldpower left.... ill try to use it anyways




Sidious Invader

Dark Lord Of The Sith

50 XP

9th January 2007

0 Uploads

853 Posts

0 Threads

#8 11 years ago

Try these tags.... TrueTrue Maybe change the fire range on the hardpoint, or the attack move range tag on the unit.




general_kerr

(Couldn't find a title)

50 XP

14th February 2007

0 Uploads

2,089 Posts

0 Threads

#9 11 years ago

HMMMMM.......... dat sucks, there has to be a way, i've never tried to make somthing use turrets, but i'm ot a modeler(well i can't rig my own models)




Guest

I didn't make it!

0 XP

 
#10 11 years ago
Sidious Invader;3942129Try these tags.... TrueTrue Maybe change the fire range on the hardpoint, or the attack move range tag on the unit.

i already included those lines in the code