FOC Exception Error in Vista -1 reply

  • 1
  • 2

Please wait...

Guest

I didn't make it!

0 XP

 
#1 10 years ago

Hello,

Recently I purchased a new computer, which came with Windows Vista. I installed Empire at War and Forces of Corruption onto the computer and every time I try to run FOC, I get an "Exception Error". I have contacted Lucasarts about this problem, but they have yet to come up with a solution.

Does anyone else have this issue? If so, were you able to correct it and how?

Thanks.




NeoDio

In KOTOR1/2 and EAW/FOC Mods!!

50 XP

4th November 2007

0 Uploads

14 Posts

0 Threads

#2 10 years ago

Fortunately, unlike KotorII, I have been able to play both SW EAW and FOC on vista home premium, I just finished all factions and now I'm trying the Mods...sad I couldn't do that with KOTOR2 :( What is your vista version? EAW setup asks to be added to the windows firewall exceptions list since the game has multiplayer mode, do you have any other software or anti-virus possibly blocking the game due to *suspicious* bahaviour?AVG and Avast! usually block games that way with no warning depending on their definitions.




Guest

I didn't make it!

0 XP

 
#3 10 years ago

I have Home Premium Version 6.0.

I also have Anti Vir virus protection on my pc. The funny thing is, is that EAW itself runs. FOC is where the Exception Error occurs. However, neither of the the games appear in my Start Menu after installation. If I want to try to run it I have to go into Windows explorer and find the .exe file.

I appreciate your help.




Guest

I didn't make it!

0 XP

 
#4 10 years ago

hey, NeoDio, i got a fix for your KOTOR2 problem if ur on vista, replace the MSS32.dll for kotor2 with the one from KOTOR1, u can get it somewhere round filefront if u dun have kotor1, or i can send it to you

as for this FoC problem, ive got the same thing and see no way of fixing it




Darth Mandalore

The ultimate sith lord!

50 XP

17th November 2008

0 Uploads

12 Posts

0 Threads

#5 9 years ago

I have exactly the same problem!




Guest

I didn't make it!

0 XP

 
#6 9 years ago

Has any of you people tried running the game with the following settings:

  • right click on .exe file and choose Properties
  • go to Compatibility tab
  • set Compatibility Mode for Windows XP (Service Pack 2)
  • enable running with Administrative Priviledges
  • disable Desktop Composition
  • click Ok and try running the game



Darth Mandalore

The ultimate sith lord!

50 XP

17th November 2008

0 Uploads

12 Posts

0 Threads

#7 9 years ago

I tried and it didn't work, exactly the same problem.:(




Darth Mandalore

The ultimate sith lord!

50 XP

17th November 2008

0 Uploads

12 Posts

0 Threads

#8 9 years ago

Sorry for double post but, I may have found the solution. I haven't tested it yet but a lot of other people have said that it works perfectly. Hope it helps. Just look for the post by mike.nl and you'll find the link:

Exception in Vista (64 bit) - Petroglyph Forums




theman88

The Force is my ally

50 XP

4th June 2008

0 Uploads

245 Posts

0 Threads

#9 9 years ago

well I might have the same problem but I dont know enough on your guys problems, First of I have a Vista 32-bit, now to the matter at hand, OK i installed the game perfect no troubles then I started the game at first I got this thing about some invalid disk and it could not comfirm it or somthing like that ( i will edit this later when i retry it) and no i did not use a crack i have the "REAL" game...I do run MacAfee if that might be stoping the game from starting I have no idea but I have ran the game about... oh 3 times with no problems when it runs just starting it. I have given the full admin on the launcher , the EXE ,and the hole folder for that matter! I will try the run as XP mode and the disable thing. I might try that link but if it envovles coding I duno.




theman88

The Force is my ally

50 XP

4th June 2008

0 Uploads

245 Posts

0 Threads

#10 9 years ago

ok its not letting me edit my post so I will post here.. ok when it does not start it says... Original disk could not be found or authenticated? could this be a problem with the blinkwll.32 or what ever? I know it was what stoped my kotor 2




  • 1
  • 2