Can't start the game :( -1 reply

Please wait...

SilentFlame

I'm too cool to Post

50 XP

9th August 2004

0 Uploads

2 Posts

0 Threads

#1 15 years ago

Hey guys, first post here. Yesterday I got back from a 3-week vacation in Poland and in the last week, I somehow really felt like playing JK2 again after a year. Today I was installing JK2, and when it was done after quite a long time, I clicked on 'play single player', and I got this screen with yellow letters, then the screen faded black, then it went back to my desktop and I got this error: -------------------------------------------------------------- [color=red]GLW_StartOpenGL() - could not load OpenGL subsystem[/color] JK2: v1.03 win-x86 May 3 2002 Initialising zone memory ..... ----- FS_Startup ----- Current search path: C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\assets5.pk3 (4 files) C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\assets2.pk3 (289 files) C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\assets1.pk3 (8011 files) C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\assets0.pk3 (6674 files) C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData/base ---------------------- 14978 files in pk3 files execing default.cfg couldn't exec autoexec.cfg ...detecting CPU, found AMD w/ 3DNow! ------- Input Initialization ------- Skipping check for DirectInput Joystick is not active. ------------------------------------ ----- Client Initialization ----- ----- Initializing Renderer ---- ------------------------------- ----- Client Initialization Complete ----- --- Common Initialization Complete --- Working directory: C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData ----- R_Init ----- Initializing OpenGL subsystem ...initializing QGL ...calling LoadLibrary( 'C:\WINDOWS\System32\opengl32.dll' ): succeeded ...setting mode 3: 640 480 FS ...using desktop display depth of 32 ...calling CDS: ok ...registered window class ...created window @ 0,0 (640x480) Initializing OpenGL driver ...getting DC: succeeded ...GLW_ChoosePFD( 32, 24, 8 ) ...35 PFDs found ...GLW_ChoosePFD failed ...GLW_ChoosePFD( 32, 24, 0 ) ...35 PFDs found ...GLW_ChoosePFD failed ...failed to find an appropriate PIXELFORMAT ...restoring display settings ...WARNING: could not set the given mode (3) ...setting mode 3: 640 480 FS ...using colorsbits of 16 ...calling CDS: ok ...created window @ 0,0 (640x480) Initializing OpenGL driver ...getting DC: succeeded ...GLW_ChoosePFD( 16, 16, 0 ) ...35 PFDs found ...GLW_ChoosePFD failed ...GLW_ChoosePFD( 16, 16, 0 ) ...35 PFDs found ...GLW_ChoosePFD failed ...failed to find an appropriate PIXELFORMAT ...restoring display settings ...WARNING: could not set the given mode (3) ...shutting down QGL ...unloading OpenGL DLL ----- CL_Shutdown ----- RE_Shutdown( 1 ) ----------------------- GLW_StartOpenGL() - could not load OpenGL subsystem --------------------------------------------------------------

I don't know much about this kind of stuff, so could anyone please help me out? I want to play this game again :(




extantrifler

FPS is my Life

50 XP

1st May 2004

0 Uploads

291 Posts

0 Threads

#2 15 years ago

Well obviously it's about OpenGL. Maybe somehow it changed the version or something.




Trauma Sensei

The All Seeing Eye

50 XP

5th June 2004

0 Uploads

1,591 Posts

0 Threads

#3 15 years ago

Do you have a graphics card that supports Opengl? Jedi Knight needs a 3d graphic accelerator. If you donĀ“t have a good g-card then you should download a software called "Gldirect" just look for it on google




SilentFlame

I'm too cool to Post

50 XP

9th August 2004

0 Uploads

2 Posts

0 Threads

#4 15 years ago

Thanks, that gldirect helped. Too bad I got this stupid trial version, it totally ruins the game because there's 'DEMO VERSION' all over the screen when I play. I'll look for another.




|GL|Niels

I don't spend enough time here

50 XP

2nd August 2004

0 Uploads

28 Posts

0 Threads

#5 15 years ago

lol just get the whole game :)