jk2config problems, need help! -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 8 years ago

I recently purchased a new computer: Windows 7 64-bit. I have never had problems with Jedi outcast on Windows XP but with the new computer I have an annoying problem:

Whenever I edit options for controls etc. in the game, and quit and open up the game again, it reverts to factory default. This is not good as I have been using my own custom set up for years.... any help? I have tried different compatibility modes... Jedi Academy doesn't have the problem. Just outcast. Also whenever I edit or use my previous jk2config.cfg file, it overwrites it to the default. It's really frustrating any help would be greatly appreciated.




Guest

I didn't make it!

0 XP

 
#2 8 years ago

There is a fix (kind of) for this problem in Jedi Academy, but I'm not sure if it'll work in Jedi Outcast too. It should, since both games use the same configuration system and share the same console commands.

In singleplayer, set all controls and other settings to your liking. Now, open the console by pressing Shift and Tilde keys together, type "write myconfig" (without the quote marks, ofcourse) and press Enter. If you did everything right, you should see a message saying "writing myconfig.cfg". That means the game has created a new configuration file with your settings stored in it. Next time you start the game, open the console, type "exec myconfig" and press Enter. A message saying "execing myconfig.cfg" should appear. Close the console and all your custom setting should be instantly loaded.

In multiplayer, everything I said above applies, but you need to add / (slash) thingie at the beginning of each command. So, when you want to create a new configuration file, type "/write myconfig" (again, without the quote marks). To load the file, type "/exec myconfig", etc. You get the idea.

When creating a new configuration file, you can give it any name you want. I just used "myconfig" as an example. Personally, I like the name "Order 66", so every time I load my custom settings, I get to exec(ute) Order 66. =p




Noxious

I'm too cute for a title.

50 XP

16th October 2009

0 Uploads

141 Posts

0 Threads

#3 8 years ago

I had this. Are you using a shortcut of some kind? If you are, right-click on it, and go to the properties. In the target box, it most likely has 'safe' in it. Just take that out and it should work fine after that.

If however, thats not the problem, then the only other way I can think to resolve it using the write config method Tricorder posted. :)




Guest

I didn't make it!

0 XP

 
#4 8 years ago

Thanks, Tricorder, that solves the problem!