Add New Animations! -1 reply

Please wait...

Wector

I'm too cool to Post

50 XP

4th August 2008

0 Uploads

15 Posts

0 Threads

#1 9 years ago

Hi guys, Just a small animation and script question:

Is it possible to add a new, custom made animation to the animation.cfg file without replacing an already existing animation and then use it in a script for a NPC? I have tired to just add a new line in the animation.cfg file and then add the same line in the "anims" file found in behaved source files. The animation appears in Behaved but not while in the game. Have I missed any important step or is it not just possible? :confused:




minilogoguy18

kitty dances for rep!

50 XP

4th September 2004

0 Uploads

2,675 Posts

0 Threads

#2 9 years ago

yeah it is possible, did you make a new gla file and merge it with the _humanoid.gla? even animations that replace have to be merged in with that, the game wont read it if its separate.




Wector

I'm too cool to Post

50 XP

4th August 2008

0 Uploads

15 Posts

0 Threads

#3 9 years ago

Yes I merged the new gla. file with the _humanoid.gla in GlaMerge, so the problem can't be that. When I replace an default animation with my new custom made animation everything works perfectly (just adding the new frame numbers in the animation.cfg file), but when I try to add it as a new animation it's like the game won't even read it. The NPC just ignore the animation and does nothing.

Also, when I look at the animtion in Modview it appears to work perfectly too.




katanamaru

Fencer, Lifter, & Dancer

50 XP

3rd February 2006

0 Uploads

1,454 Posts

0 Threads

#4 9 years ago

Right now you're being a little vague on what you are trying to do. Are you trying to add an animation to JA that is referenced in a npc file? Something like a new attack or such? Are you trying to make something that has to be coded in? Adding new animations to MP requires coding and adding animations to SP isn't possible without replacing. You could try replacing a unused animation like the sleep animations and try that.




Wector

I'm too cool to Post

50 XP

4th August 2008

0 Uploads

15 Posts

0 Threads

#5 9 years ago

sry for not being clear enough, but I think you gave me an answer. I simply want to "adding animations to SP without replacing". Too bad that doesn't work though :(




DrAshgod

You know me as TheExile

50 XP

7th April 2008

0 Uploads

274 Posts

0 Threads

#6 9 years ago

Um... Sometime I get this problem... I usually fixing by merging a random animation and put it it animation.cfg file... Then the animation will work, but the random one you added won't... Unless this fixes totally the problem.




N-7

... and a nice big Cip-Quad

50 XP

20th September 2007

0 Uploads

579 Posts

0 Threads

#7 9 years ago

I think the usable sequence names are hard-coded (if you have the SDK, look into codemp/cgame/animtable.h; I know you want it for sp not mp, but most likely they're similiar in this regard). Have you tried using one of 'BOTH_CIN_1' ... 'BOTH_CIN_40'? I take it they're supposed to be used for level-specific cinematic animations, but maybe they'll work for your purpose as well.




Wector

I'm too cool to Post

50 XP

4th August 2008

0 Uploads

15 Posts

0 Threads

#8 9 years ago

hah, you were right, when adding BOTH_CIN_1 at the end of the animation.cfg file with my new frames it worked perfectly :D thanks for tip mate




katanamaru

Fencer, Lifter, & Dancer

50 XP

3rd February 2006

0 Uploads

1,454 Posts

0 Threads

#9 9 years ago

That's kind of what I said. Instead of replacing something like a cinematic you could replace an unused animation like the sleeping ones. Those were for JO when Kyle rescues Jan. Replacing those JO animations will keep all the base JA ones and allow you to add your own.




Wector

I'm too cool to Post

50 XP

4th August 2008

0 Uploads

15 Posts

0 Threads

#10 9 years ago

yes but the tricky part is that the "BOTH_CIN_1" is not in the "_humanoid/animation.cfg" file, you need to add a new line at the end of the file.