Am I Using The Right Program -1 reply

Please wait...

Forsey

I don't spend enough time here

50 XP

13th May 2007

0 Uploads

21 Posts

0 Threads

#1 11 years ago

I've been using JK2 Radiant, and have been doing tutorials on it for the past week. In a previous thread I made in which I was replied to with this

DracoLich;3677932O .... M.... G

You are using JK2Radiant?!?!?! o_0

Try getting 1.4, it has many more possibilities.

I'm just wondering what program you guys use to make your maps? and where can I get this 1.4? If I'm using an out of date program I'd like to know where I could catch myself back up in time. In the stickied thread I seen GTKRadiant 1.5.0 (Windows) and GTKRadiant 1.4.0 which would you guys recommend I use? Which is the most up to date and why is there 2 available?

**EDIT** BTW I'm using version 1.3.1072




Inyri Forge VIP Member

[Insert User Title Here]

55 XP

15th March 2005

0 Uploads

25,940 Posts

0 Threads

#2 11 years ago

GTKRadiant 1.4 is hailed as the 'best' version of Radiant by many veteran mappers. It is not yet known whether this is because they are all old farts ( ;) ) or because it truly is better. GTKRadiant 1.5 is the newest version. Typically odd-numbered builds are less stable, but you'll find people who will swear upon GTK 1.5, and possibly gamble away their grandmother's life savings under the assumption that it's the best thing since sliced bread.

I think, on average, a greater number of people use 1.4, so you'd be more likely to be able to receive accurate assistance for 1.4.




Guest

I didn't make it!

0 XP

 
#3 11 years ago

I can't find 1.4 on QERadiant.com anymore, anyway. Only the newest build, 1.5.

My oppinion is that you get 1.5, but thats me.




Innocent Hawk

Not so innocent?

50 XP

18th July 2005

0 Uploads

207 Posts

0 Threads

#4 11 years ago

Get 1.4. I see you already found the link, so that is good.

One of the reasons why I recommend 1.4 is because the entity window has a load of extra useful buttons and a ton of information on how to really get the most out or your entities, door, breakable objects, etc., etc. Anybody who tells you to use 1.5 is just a guy drooling over it's prettier looking buttons. ;) Stability has never been a problem in any build I have ever seen. I used to use 1.3.12 for a very long time, because it was familiar and reliable. I never had any stability problems with it. When the 1.5 beta came out I used it for about 5 minutes then threw it away (and when I got my new computer I tried the newest/complete version of 1.5, and still threw it away). Now I use 1.4 because it has the comforts and reliability as 1.3.12, and I supposedly get more stability, even though I never had a problem with that in the past.




Bluestormtrooper

>You

50 XP

14th March 2005

0 Uploads

1,752 Posts

0 Threads

#5 11 years ago

Ummm...if you mean the information in the entity window about that particular entity, then 1.5 has that too. You just need to drag down the dotted bar at the top.




DracoLich

~Senatu

50 XP

11th January 2006

0 Uploads

212 Posts

0 Threads

#6 11 years ago
Originally Posted by DracoLich O .... M.... G You are using JK2Radiant?!?!?! o_0 Try getting 1.4, it has many more possibilities.

You alredy have my words :) Get 1.4, 1.4 FTW! :stallard:




DemonCloud

Chapter Master of the Ultrians

50 XP

4th May 2007

0 Uploads

488 Posts

0 Threads

#7 11 years ago

another thing thats better in 1.4 (atleast for me) is that textures are working, on 1.5 no texture is showing up




Ayala

Lurker

50 XP

3rd August 2005

0 Uploads

93 Posts

0 Threads

#8 11 years ago

I found that it was easier to go through the common tutorials (see Rich Diesel's tutorial) using 1.4. Version 1.5 is set up slightly different and I personally believe it's harder going through the tutorials using 1.5.




iswer

Mapper, Modeller, Musician

50 XP

18th April 2004

0 Uploads

1,601 Posts

0 Threads

#9 11 years ago

I like 1.5 most for building the map up and texturing, and 1.4 for lightning, and compiling.




Green-Flash

The trigger_hurt of the forums

50 XP

4th April 2007

0 Uploads

56 Posts

0 Threads

#10 11 years ago

Yeah I personaly use 1.4 too, it's much easier to use and is gneraly better.

Also you will find that most tutorials are based on using 1.4.