Carcass Compile error -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 14 years ago

hi, i keep getting this error in carcass Carcass (GLA/GLM compiler) v2.1. (C) Raven Software 1998-2003. Written by Gil Gribb, Ste Cork, James Monroe, Mike Crowns -------- C:\base\models\players\_humanoid\Untitle2d.car -------- ( Build trigger: "c:\base\models\players\_humanoid\untitle2d.glm" missing ) entering c:\base\models\players\_humanoid\untitle2d.car (90 degree skewing OFF) Loading GLA "models/players/_humanoid/_humanoid.gla"...21376 frames Grabbed 1 files with 21376 frames Processing 'c:/base/models/players/_humanoid/root.XSI' Processing meshes, LOD 0 Processing meshes, LOD 1 (Mesh empty, so total LODs = 1) Generating Untitle2d.glm ... ( scale: 0.64 ) Writing Untitle2d.glm ... Writing MDX/GLM model file... ( skin-write inhibited ) Building GLM... Error: Surface 'hips' has 1079 verts, max is 1000! ************************************************************************ Warning: Surface can't use shadows, #verts(1079) > SHADER_MAX_VERTS/2 (500) ( "hips" ) ************************************************************************ ************************************************************************ Warning: Surface can't use shadows, #verts(733) > SHADER_MAX_VERTS/2 (500) ( "torso" ) ************************************************************************ ************************************************************************ Warning: Surface can't use shadows, #verts(528) > SHADER_MAX_VERTS/2 (500) ( "r_hand" ) ************************************************************************ ************************************************************************ Warning: Surface can't use shadows, #verts(527) > SHADER_MAX_VERTS/2 (500) ( "l_hand" ) ************************************************************************ Error: Surface 'head' has 1421 verts, max is 1000! ************************************************************************ Warning: Surface can't use shadows, #verts(1421) > SHADER_MAX_VERTS/2 (500) ( "head" ) ************************************************************************ ( Press any Key ... ) is there any way to raise those limits or do i really have to cut the polycount of my model?




minilogoguy18

kitty dances for rep!

50 XP

4th September 2004

0 Uploads

2,675 Posts

0 Threads

#2 14 years ago

you have to cut the poly count of just the hips because none of the others are over 1000




Guest

I didn't make it!

0 XP

 
#3 14 years ago

hmm alright, but when i look up the polycount in 3dsm /milkshape the hips are @ ~ 500 polies nothing more, why does carcass say its above 1000 o.o?




Humble Jedi

Grammar and spelling Knight

50 XP

17th June 2005

0 Uploads

201 Posts

0 Threads

#4 14 years ago

I am not sure about this, but look for a variable "backfaceing" and ensure it is turned off. (Bear in mind I havent used max since i left school, so i may be thinking of the qrong program) but if this is right, then it means that it is trying to draw the back AND front of polys, so they would double (explaining your problem)




Guest

I didn't make it!

0 XP

 
#5 14 years ago

im pretty sure that it counts the backfaced polies too. well i just found out that the error is gone when i apply vertex (ignoring smoothing groups) in .xsi export.




.The Deviant

Second Tier Wise-ass

50 XP

6th March 2005

0 Uploads

1,444 Posts

0 Threads

#6 14 years ago

What're you trying to export =D? What model.? =D.




oodoo7

the light never return

50 XP

9th July 2005

0 Uploads

88 Posts

0 Threads

#7 14 years ago

well, Error: Surface 'hips' has 1079 verts, max is 1000! <== this report over max 1000 (if u use 3D max, u will see the number of surfaces or vertext when u count them.) you might have 2 options, one is reduce your surface or vertext, the other is detach to new object, let s say hips_01...BUT...you will have the hard task to do linking hierarchy (always make you confuse, if you dont understand it clearly) Warning: Surface can't use shadows, #verts(1079) > SHADER_MAX_VERTS/2 (500) ( "hips" ) <== this report that you have bad vertex or bad surface. If you check them carefully, you will see non-enclose surface or illegal vertex rule ( rule of 1 surface consist of 3 or 4 points with the right orientation).




Almighty_gir

Mutated Inyri Clone No#00001.5

50 XP

21st July 2004

0 Uploads

1,379 Posts

0 Threads

#8 14 years ago

uhhh well heres a hint, stop just counting polies -_- theres 3 verticies per polygon, so if you have 500 triangles, your gonna have around 1000 ish verticies. so just cut down on the polycount in general (i cant see why you would need 500 triangles just on the hips anyway, it only takes me 1500 triangles for a whole model O_O)