Effect Problem. -1 reply

Please wait...

SithDagger

Dark Lord Of The Sith

50 XP

7th May 2005

0 Uploads

534 Posts

0 Threads

#1 13 years ago

umm I am making some weapons, and rigging the effect files to work differently. For some reason the actual painted gun 'shots' show up, but with a grey and white square around them. See here: http://i5.photobucket.com/albums/y165/SithDagger/JAProblems/Problem1.jpg http://i5.photobucket.com/albums/y165/SithDagger/JAProblems/Problem2.jpg http://i5.photobucket.com/albums/y165/SithDagger/JAProblems/problem3.jpg I dunno how to fix them to look right, I even used a shader, which I programmed to be the exact same as the weapon effect shaders. So I dunno...




Inyri Forge VIP Member

[Insert User Title Here]

55 XP

15th March 2005

0 Uploads

25,940 Posts

0 Threads

#2 13 years ago

Looks like you'll need a transparency shader (which means having alpha channels). Try something like this: path { cull disable { map path alphaFunc GE192 depthWrite rgbGen lightingDiffuse } }Just make sure you have alpha channels, or it won't work.




SithDagger

Dark Lord Of The Sith

50 XP

7th May 2005

0 Uploads

534 Posts

0 Threads

#3 13 years ago

I tried using the shader you posted, all I got where a whole lot of errors. I use shaderEd, so I hit the Alpha Channel, and the Alpha Sort buttons, but I still get the same pictures as posted above.




SithDagger

Dark Lord Of The Sith

50 XP

7th May 2005

0 Uploads

534 Posts

0 Threads

#4 13 years ago

here is the shader I am using gfx/morrowindweapons/glassboltfront { q3map_nolightmap q3map_alphashadow { map gfx/morrowindweapons/glassboltfront blendFunc GL_ONE GL_ONE rgbGen vertex } }




SithDagger

Dark Lord Of The Sith

50 XP

7th May 2005

0 Uploads

534 Posts

0 Threads

#5 13 years ago

and this one gfx/morrowindweapons/glassboltside { q3map_nolightmap q3map_alphashadow { map gfx/morrowindweapons/glassboltside blendFunc GL_ONE GL_ONE rgbGen vertex } }




Inyri Forge VIP Member

[Insert User Title Here]

55 XP

15th March 2005

0 Uploads

25,940 Posts

0 Threads

#6 13 years ago

ShaderED is dumb, just use notepad. Make sure you have alpha channels in your image. Can't stress that enough. If you don't, you'll get that error regardless of what shaders you use.




SithDagger

Dark Lord Of The Sith

50 XP

7th May 2005

0 Uploads

534 Posts

0 Threads

#7 13 years ago

in my image? that could be the problem. How do I do that? I use PSP8, I dont know how to add alpha channels.




Inyri Forge VIP Member

[Insert User Title Here]

55 XP

15th March 2005

0 Uploads

25,940 Posts

0 Threads

#8 13 years ago

:google: :thumbsup: Always check.




.The Deviant

Second Tier Wise-ass

50 XP

6th March 2005

0 Uploads

1,444 Posts

0 Threads

#9 13 years ago

Theres a tutorial for setting up alpha channels in photoshop in the tutorials sticky, but if you dont have photoshop, I just got Photoshop CS2, And i'm ITCHING to try it out, so you can go ahead and send it if you cant get it to work.