First Skin -1 reply

Please wait...

SpawnHyuuga

Mass Trooper #364

50 XP

17th August 2006

0 Uploads

177 Posts

0 Threads

#1 8 years ago

I'm trying to make my first skin, but have run into troubles. I made all the graphics and even made bot and npc files and compiled it into a pk3. Now when I start the game however, the bot's name is in black; and is the default kyle. What's up with it?




Inyri Forge VIP Member

[Insert User Title Here]

55 XP

15th March 2005

0 Uploads

25,940 Posts

0 Threads

#2 8 years ago
EGMulti;5045240What's up with it?

You probably did something wrong. Couldn't tell you exactly what with so little information, unfortunately. Make sure the pathways are all correct, your PK3 is formatted correctly, and the bot files are all correct.




SpawnHyuuga

Mass Trooper #364

50 XP

17th August 2006

0 Uploads

177 Posts

0 Threads

#3 8 years ago

I hate to say it, and yes I fully intended upon writing my own bot and npc scripts before releasing, but I borrowed the files from one of the source files I was using. What do I use to open. I do believe I changed the skins.gln or whatever with notepad, as well as the sounds.cfg.

EDIT: If I post the .pk3, can someone take a look at it?




Inyri Forge VIP Member

[Insert User Title Here]

55 XP

15th March 2005

0 Uploads

25,940 Posts

0 Threads

#4 8 years ago

Yes, someone can look at it if you post it.




SpawnHyuuga

Mass Trooper #364

50 XP

17th August 2006

0 Uploads

177 Posts

0 Threads

#5 8 years ago
Inyri Forge VIP Member

[Insert User Title Here]

55 XP

15th March 2005

0 Uploads

25,940 Posts

0 Threads

#6 8 years ago

Your directory structure is faulty. It should be players and ext_data, not player and ext-data. Make sure to double and triple check these simple things if your mod isn't working properly. :)




Averus_Retruthan

...Or has it just begun?

50 XP

19th September 2006

0 Uploads

473 Posts

0 Threads

#7 8 years ago

Just checked it, and the Lady Forge is indeed correct. Also, the black name is the result of your shoop.bot's name having a ^0 in front of it, which is the Q3 text code for black.

So, quick checklist of things to do:

- edit model_default.skin so that is reads models/players/shoop in the entries

- repackage directory into models/players/shoop

- repackage ext_data/npcs

- repackage the sounds into sound/chars/shoop/misc*

- remove ^0 from your .bot file if you want the name uncolored

*You will actually have to resample your sounds, since the game's picky about the rate and what not. 44100 Hz Mono. I figured you have enough work on your plate as is, so I cut you a break:

http://www.arsu.net/epsalon89/Resampled%20Sounds.zip

I'll leave you to remake the sound directory, since it was composed of just those two sounds ¬_¬




Mert Karamolo

Inventor of "Duderism"

50 XP

16th May 2009

0 Uploads

133 Posts

0 Threads

#8 8 years ago

[COLOR=seagreen]Maybe the best thing to do... if your in trouble with this kind of problem.... you should download a other model/skin and see what that has what yours doesnt have... that might help.[/COLOR] [COLOR=seagreen]It always works for me!:p[/COLOR]




SpawnHyuuga

Mass Trooper #364

50 XP

17th August 2006

0 Uploads

177 Posts

0 Threads

#9 8 years ago

Thanks for the quick fixes. I wasn't too worried about the sound. It's from the Shoop Da Whoop Reborn on JK3Files. I am going to add a whole lot more sounds anyways. I used the generic wookiee model file on here, to start; did the skinning; and borrowed the sounds. The quality of them sounded quite low anyways; and the lazer sound was bothering me.

EDIT: Does anyone know how to go about making a custom npcs, and bot file. I prefer to use my own stuff, instead of someone else's. Like I said I am only using the files temporarily; it was strictly for testing purposes. Ripping off someone else is not cool; and I'm too lazy of an arse to try and contact them.

EDIT 2: I am so happy, I got my butt handed to me by some bots today in ForceMod. I can't believe I was actually losing; instead of coming out 50(Me)-7(2nd place Bot). Instead I kept dying. I still say ForceMod, and JAPlus together would be ftw.

EDIT 3: Has anyone ever tried to push Jedi Academy to it's limits? I'm really considering trying to learn everything I need to make a real decent mod, that might give JA a hopeful resurrection, because I have to say it's kind of dead around here. A lot of people who like the controls and stuff are still around. But, let's face it - this game needs some new features, some collaboration and teamwork, and some HD grafx.

EDIT the 4th: I looked at the botfile - and in it's "name" of the file I see no zero. Are you guys talking about somewhere in the file? If so, what do I use to open it, notepad?

Anyone who can answer these questions, please do.

[Edit]I fixed the text stuff, everything except for the black name, which is more of a nuisance than anything, but now when I play the skin is invisible. I thought I would at least see the mouth, tho. Is it because the skin is black? If so, does the game make all shades of black invisible, or just 0,0,0? Like for instance is 0,0,1 going to show up?[/Edit]




Lord Suibuku

I don't spend enough time here

50 XP

23rd July 2009

0 Uploads

29 Posts

0 Threads

#10 8 years ago

There are a couple of reasons why a skin could be invisible, one there could be missing textures, two you could have messed something up in the .skin file (model_default.skin) TO make a skin file you have to change the directory, the name of your folder were all your textures are, for example- in red below you see the directory name. In blue that is what the file name is. You must change the directory name from "wookie" or whatever it is to "shoop_da_wookie" or something like that. When you change the folder name you have to change the directory located in red. Don't touch the Stormtrooper caps, located in green. If you forget to do this your skin will come out invisible. hope this helps!

hips,models/players/[COLOR=Red]suimk_scorpion[/COLOR]/[COLOR=Blue]legs.tga[/COLOR] r_leg,models/players/suimk_scorpion/legs.tga r_leg_cap_hips_off,models/players/[COLOR=Lime]stormtrooper[/COLOR]/caps.tga l_leg,models/players/suimk_scorpion/legs.tga l_leg_cap_hips_off,models/players/stormtrooper/caps.tga torso,models/players/suimk_scorpion/torso.tga r_arm,models/players/suimk_scorpion/arms.tga

For the botfiles

I believe they are talking about the .bot file located in the scripts folder.

Example-

{ name "[COLOR=Magenta]Wolverine[/COLOR]" model [COLOR=Orange]wolverine_sui_v1[/COLOR] color1 none color2 none saber1 "" saber2 "" personality /botfiles/Wolverine.jkb }

Located in pink is the name 0^ is the code on the quake engine to make a color. Model in orange is the folder name of the skin, the name of model has to be the same as the folder name. (the folder were your textures are)

To be honest about the .jkb you probably have to copy someone elses and modify it. there really isnt any other way that I know of.

~Lord Suibuku