func_rotating problem -1 reply

Please wait...

mike elf

:)

50 XP

12th January 2005

0 Uploads

83 Posts

0 Threads

#1 11 years ago

I been trying for quite some time now to do this: Get a valve to rotate, but only for 3 seconds and then stop. Ive got it rotating fine its just getting it to do so for 3 seconds and then stop that i dont know how to do. If i could get it to decelerate that would be even better... but i have no idea how to do that either. Any help would be very grateful.




ƒul*£ruM

I'm too Post to cool.

50 XP

24th November 2006

0 Uploads

449 Posts

0 Threads

#2 11 years ago

try putting a switch that triggers it, the switch should have a wait value of 30 (or 30000, im not sure if its in ms or s)




mike elf

:)

50 XP

12th January 2005

0 Uploads

83 Posts

0 Threads

#3 11 years ago

No that doesnt work - the wait with a value of 3 just means id have to wait 3 seconds before i can reuse the trigger. the trigger is a trigger_once anyway so wait doesnt mean anything. good suggestion though




ƒul*£ruM

I'm too Post to cool.

50 XP

24th November 2006

0 Uploads

449 Posts

0 Threads

#4 11 years ago

try putting a wait value on the rotating entity(has to have the 'Inactive' checkbox checked and be rigged to a switch) Does this work?




mike elf

:)

50 XP

12th January 2005

0 Uploads

83 Posts

0 Threads

#5 11 years ago

no - putting a wait command on the rotating entity means that its just waiting for nothing... having inactive checked means it doesnt rotate because it needs a target_activate to work and its coming from a trigger. Having a target_activate instead of the trigger wouldnt change anything because it would just do the job of the trigger_once. This might be a job for scripting but i only started doing that 2 weeks ago so i have no idea where to start...




ƒul*£ruM

I'm too Post to cool.

50 XP

24th November 2006

0 Uploads

449 Posts

0 Threads

#6 11 years ago

dont look at me




Insecure

:)

50 XP

7th November 2005

0 Uploads

286 Posts

0 Threads

#7 11 years ago

As far as I know, the Q3 engine does not support func_trains, func_rotatings, or any other func_ that stops midway. As far as decelerating goes, i'm sure you could whip up a script for that. Provided youre modding for jka and not jko that is.




ƒul*£ruM

I'm too Post to cool.

50 XP

24th November 2006

0 Uploads

449 Posts

0 Threads

#8 11 years ago

erm this is JA editing forums.... so im pretty sure that he is talking about JA




mike elf

:)

50 XP

12th January 2005

0 Uploads

83 Posts

0 Threads

#9 11 years ago

yeah this is for jka - could someone who knows what their doing please 'whip' up a script for me. (ful*crum's name is very apt for this topic)




ƒul*£ruM

I'm too Post to cool.

50 XP

24th November 2006

0 Uploads

449 Posts

0 Threads

#10 11 years ago

you made funna me? :dropsjaw: this is what i will do to you! :micro:

hey dont make funna me!