GTK Radiant 1.4 on Windows 7 Ultimate -1 reply

Please wait...

DarthStevenus

GF is my bext friend *hugs GF*

50 XP

18th December 2009

0 Uploads

909 Posts

0 Threads

#1 8 years ago

Just got a new laptop yesterday and I've been going through it and installing all my modding tools such as gimp, gmax, radiant, etc. etc. I got no error messages after installing radiant but when I open it the 2d, 3d, and texture windows are all either plain gray or when I load a map they get all mixed up. For instance when I loaded t2_rancor the textures were in the 3d viewport, the 3d view was in the 2d viewport, and the 2d view was nowhere to be seen. Has anyone else had these problems or know how to fix them? Or can radiant 1.4 just not run properly on windows 7 ultimate?




Guest

I didn't make it!

0 XP

 
#2 8 years ago

Easy solution http://jediknight3.filefront.com/file/GTKRadiant_for_Jedi_Academy;19845

If you don't fancy that then try running in compatibility mode, disabling visual themes etc.




Jonny2199

Click >HERE< to find an idiot.

50 XP

18th September 2005

0 Uploads

1,046 Posts

0 Threads

#3 8 years ago

I know that some people 'round here don't especially like GTK 1.5.0 but I use it. I don't make anything worth sharing, mind. Anyway, it's similar to 1.4 as far as I can remember. Check the preferences menu for a layout option (in 1.5.0, it's Edit > Preferences > Interface > Layout) to swap the views around as required.

As for the greyness? As MUG wisely suggested, compatibility, run as admin, disable visual themes (the usual right-click please-work Vista/7 things) and also, see if it has the same problem that 1.5.0 had on Vista. Namely, it has an in-built theme that screws it up. In 1.5.0, look in \GtkRadiant 1.5.0\etc\gtk-2.0 for a file (with no file type!) called 'gtkrc' and open it in Notepad/similar and see what style it is. 1.5.0 has 'Clear Looks' set as the default, but sometimes this needs changing to 'Raleigh' to get it to work. Good luck, and I hope someone more coherent than myself can help you more.




DarthStevenus

GF is my bext friend *hugs GF*

50 XP

18th December 2009

0 Uploads

909 Posts

0 Threads

#4 8 years ago

Hmm...tried disabling visual themes, compatibility mode, and running as an administrator and nothing changed. I'll keep searching around for other people who have the same problem and see if they fixed it. And I think I'll try gtk 1.3 also. Thanks guys.

EDIT: Success! Found this link: Radiant Level Design Tools and under windows vista and windows 7 users it tells you to click Disable Desktop Composition. Did that and now it seems to work perfectly. Thanks again guys.