help. shader not working in SP -1 reply

  • 1
  • 2

Please wait...

Guest

I didn't make it!

0 XP

 
#1 10 years ago

for my own personal use i grabbed a few hilts from multiple mods to put them into my own so i have much nicer hilts to choose from in single player. but when trying to port Revan Darks from MP to SP the shaders refuse to work in single player but they work perfectly in MP, all nice and shiny.

trying to port them from this file Revan Dark Star Wars Hilts, Jedi Knight 3 Downloads, Jedi Knight 3 Packs

anyone have any idea why this would happen. it's the same game engine and I've done everything i can think of to the files.

any help would be great tearing my hair out over this.




Guest

I didn't make it!

0 XP

 
#2 10 years ago

Porting? Did you get permission from the author first?




lassev

Degenerate scripter

50 XP

21st June 2004

0 Uploads

847 Posts

0 Threads

#3 10 years ago

He needs no permissions if he only wants to use them on his own system to ogle at it in SP.

Still, I can't see why shaders wouldn't work. More likely the model (or saber data) didn't properly port to the SP for some reason or in your process you did something wrong and dropped some crusial component or a reference to it.

What error message did you get in SP? Well, I'm no saber expert so I can't really help. It's enough trouble to get some random player skin to work properly in SP already...




iswer

Mapper, Modeller, Musician

50 XP

18th April 2004

0 Uploads

1,601 Posts

0 Threads

#4 10 years ago

Why would you like to port it to Sp, when the review says it has single player support already?




Guest

I didn't make it!

0 XP

 
#5 10 years ago

@jedi_sabrina: yea i'm doing it for myself. not to release publicly.

@iswer: They never showed up in the saber selection screen. and even using the cheats to get them the shader didn't work so i replaced the original sabers with these wanting better looking ones.

@Iassev: got no error message at all. edited the shader and sab files to point to saber_2 instead of the original as i did with 2 other sabers already (obviously i put them in different ones) and then when in the game the shader doesn't seem to work. theres no shine on the hilt. and then in multiplayer. both the replaced original and the MP ones are all nice and shiny.




Guest

I didn't make it!

0 XP

 
#6 10 years ago

sry to double post but any ideas?




Skrie

Teh Totalconverterer !

50 XP

29th December 2006

0 Uploads

114 Posts

0 Threads

#7 10 years ago
Jedi_Sabrina;4344933Porting? Did you get permission from the author first?

These sort of replies really piss me off tbh. He just wants to pimp his own jedi academy using the work of others as we all do.

dexter3.jpg




Mikouen VIP Member

What?

145,650 XP

4th September 2005

4 Uploads

11,732 Posts

2 Threads

#8 10 years ago

And what, I suppose modders saying "Fuck this dead-end community, stupid kids have no respect for anyone but themselves?" doesn't piss you off?

It's simple common courtesy. You want to port something made by another modder, you ask first. You want to mess with someone's work in general, you ask first.

If you can't show a little common decency towards people when they waste hours of their lives making high-end content for you, then why the hell should they even bother?

This modding community has seriously suffered in recent years, and your attitude is a prime example of why. Y'all get so pissed off when people don't show any courtesy towards you, yet you similarly fail to show any courtesy towards anyone else. I don't know whether to call that a perpetual cycle or a causality loop.

So, do yourself - and the rest of us - a favour. Stop being so narrow-minded and short-sighted, look at the bigger picture for once. People are only half way towards sentience if you think about every effect to their actions, rather than just how an action will affect them.

Kids today. :cort:

This, however, wouldn't fall under porting. It's an add-on for an add-on, in which the original product is not modified at all. You make a skin, and I decide to make a seperate soundpack which works for a skin, your work is left as-is and I've just made a seperate work that operates by itself in tandem with the skin.

neok182, just as a note for future reference, our Modding Tutorials & Tools thread is pinned at the top of the Modding & Editing forum. It's good practice to read 'sticky' threads first on any forum, they're generally filled with the useful stuff people commonly ask about.

As for the hilts, there are two ways. The simple way and the complex way.

The simple way, just use the /saber command in SP to get them, the same way you would in MP.

The tricky way adds them to the menu as selectable, but is more complex and may conflict with other mods which add sabers to the menu. Check that Tutorials & Tools thread, the second post is a walkthrough on the process of adding hilts to the SP menu.


I don't know how, and I don't know why, but this is totally Sheep's fault.



Guest

I didn't make it!

0 XP

 
#9 10 years ago

@Kouen: yea i know the easy and complex way. i've done this many times before. thats not the problem. they show up. But the shader doesn't work in single player. in multiplayer they're all nice and shiny and in single no shine and they're all matte colors.

so again, i have no problem getting them into single player either doing the hard or simple way. but no matter what i do the shader doesn't work in single player at all but in multiplayer it works perfectly.




Skrie

Teh Totalconverterer !

50 XP

29th December 2006

0 Uploads

114 Posts

0 Threads

#10 10 years ago
Kouen;4347050And what, I suppose modders saying "Fuck this dead-end community, stupid kids have no respect for anyone but themselves?" doesn't piss you off?

LOL.

It might ! But generaly, this is a nice board where people get actuall help. So... we don't have that problem. yet.

And to Neo...

Why don't you post a pk3 with what you have so far... If I take a look at it, I might see why the shaders don't work in SP.




  • 1
  • 2