HUD Issues -1 reply

  • 1
  • 2

Please wait...

WalkerTR91

I'm too cool to Post

50 XP

22nd December 2006

0 Uploads

12 Posts

0 Threads

#1 8 years ago

Hello, I'm trying to create a hud from scratch and I'm encountering some problems. I have the images made and properly overlapping for the left side of the hud, and I want to keep them in .png format if possible. I've edited the hud.menu file to relocate the hud to where I want it and changed the rectangle size to match the size of the files, and changed the extensions to .png in the code. When I go ingame to check this out, my hud ends up being a large missing texture box with giant versions of the default red health tics overlapping on it. Any idea what's going on? If needed I can post the files.




Raz0r

Worse than most terrible

50 XP

27th September 2006

0 Uploads

6,737 Posts

0 Threads

#2 8 years ago

You don't need to add the extensions. As for the size issue, remember that is in game screen coordinates, which is drawn to a 640x480 virtual screen and then scaled up. You'll need to do some math to get the size right.




WalkerTR91

I'm too cool to Post

50 XP

22nd December 2006

0 Uploads

12 Posts

0 Threads

#3 8 years ago

Is that why it's a large untextured box?




eezstreet

Lord of the .DCC files

50 XP

16th June 2008

0 Uploads

2,662 Posts

0 Threads

#4 8 years ago

Untextured box means that the shader/texture is missing.




WalkerTR91

I'm too cool to Post

50 XP

22nd December 2006

0 Uploads

12 Posts

0 Threads

#5 8 years ago

O.o It's not missing. It's right where it's supposed to be. =/




Raz0r

Worse than most terrible

50 XP

27th September 2006

0 Uploads

6,737 Posts

0 Threads

#6 8 years ago

Not really. The game will attach the extension itself, so it's probably looking for gfx/hud/blah.png.tga




The One and Only

I R Scary Eyeball

50 XP

28th January 2004

0 Uploads

4,091 Posts

0 Threads

#7 8 years ago

Are your image dimensions powers of 2? If not they won't display.




WalkerTR91

I'm too cool to Post

50 XP

22nd December 2006

0 Uploads

12 Posts

0 Threads

#8 8 years ago

Ok well I made them .tga with a proper Alpha 1 channel and removed the extensions in the hud.menu and scaled the sizes, but it's still a gray box. I don't understand. Should I be saving the files in some special format? I used .tga 32 bit.

Ohh I'll try that. Thank you.

[Edit]Thank you very much, that worked! <3[/Edit]




PANIC98

Sneaking to n0es house

50 XP

22nd July 2009

0 Uploads

983 Posts

0 Threads

#9 8 years ago

Also do you have two seperate hud boxes to read




Raz0r

Worse than most terrible

50 XP

27th September 2006

0 Uploads

6,737 Posts

0 Threads

#10 8 years ago

What does it matter?




  • 1
  • 2