I need help with some glow shaders -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 6 years ago

Hello,

I need help making the green parts of this model glow:

Skjermbilde.PNG

The black parts aren't supposed to be there, as I want it to be transparent, while still making it glow. I've tried different kind of shaders, but for some reason none of them seem to work :|




Jeff_Katarn

jediwannabe on

50 XP

1st January 2011

0 Uploads

218 Posts

0 Threads

#2 6 years ago

You can make the blade's texture like a TGA with alpha channel, and use GL_ SRC_ALPHA GL_ONE_MINUS_SRC_ALPHA in the blendFunc. Without forgetting, of course, to use the 'glow' line.




Silverfang22

Knight Fall Operative

50 XP

7th January 2007

0 Uploads

485 Posts

0 Threads

#3 6 years ago

Why not just use the blendfunc to make black transparent? That would be more logical.




Jeff_Katarn

jediwannabe on

50 XP

1st January 2011

0 Uploads

218 Posts

0 Threads

#4 6 years ago

Is it 'blendFunc Add' then? I think I forgot it.




Guest

I didn't make it!

0 XP

 
#5 6 years ago
Silverfang22;5608283Why not just use the blendfunc to make black transparent? That would be more logical.

I tried this, but with no luck. Not even simple glow shaders work. I have dynamic glow turned on, and the textures are 512x512, .TGA. In-game textures from the base game still glow like they should, however. Any idea why it's not working?




Raz0r

Worse than most terrible

50 XP

27th September 2006

0 Uploads

6,737 Posts

0 Threads

#6 6 years ago

Upload and post the source image, as-well as the current shader you're using.




Guest

I didn't make it!

0 XP

 
#7 6 years ago

Normal glow texture (link) Lower transparent glow texture (link)

Shaders:

models/weapons2/bioclaw/bio1_glow { { map models/weapons2/bioclaw/bio1_glow blendFunc GL_ONE GL_ZERO rgbGen lightingDiffuse } { map models/weapons2/bioclaw/bio1_glow blendFunc GL_ONE GL_ONE rgbGen identity detail glow } }

models/weapons2/bioclaw/bio2 { { map models/weapons2/bioclaw/bio2 blendFunc GL_ONE_MINUS_DST_COLOR GL_ONE depthWrite glow } }

models/weapons2/bioclaw/bio3 { { map models/weapons2/bioclaw/bio3 blendFunc GL_ONE_MINUS_DST_COLOR GL_ONE depthWrite glow } }




DarthStevenus

GF is my bext friend *hugs GF*

50 XP

18th December 2009

0 Uploads

909 Posts

0 Threads

#8 6 years ago

When finishing your model, did you remember to open it in md3View, apply a skin, and export it as an md3 again? I seem to remember having this same problem, and it turned out it was because I forgot to do that. The model still showed up in-game, but none of my shaders were working.

Also, if I understand correctly what you're trying to do with your shader, you wouldn't really need a lot of what you have there now. For instance, this would probably do just fine:

models/weapons2/bioclaw/bio1_glow { { map models/weapons2/bio1_glow blendFunc add glow } }




Guest

I didn't make it!

0 XP

 
#9 6 years ago

Looks like it works now, thanks a bunch <3