Mine Monster -1 reply

Please wait...

lordzapharos

Kleptoleech - Hide your money!

50 XP

1st September 2006

0 Uploads

45 Posts

0 Threads

#1 10 years ago

Is there any particular reason why, when I spawn the minemonster (originally from JK2 as we all know, but also an unused npc in JK3), it will not move of its own accord? When I spawn the npc, it will attack me if I'm close enough, but it will only move when I move my character - otherwise it will pause a short distance away from me, almost as if it were an ally.

I want to use the minemonster in JK3 - is there any way to get over this strange problem?




NAB622

EAT ME!

50 XP

8th October 2005

0 Uploads

6,921 Posts

0 Threads

#2 10 years ago

Are you using JA+? It has a knack for doing that with most NPCs (howlers, for instance).




jk3editor

Retard Hungarian Modder

50 XP

21st August 2008

0 Uploads

1,520 Posts

0 Threads

#3 10 years ago

[COLOR=Navy]I wanted the minemonster too in JK3, so I copied two folder from the JK2 to the base of the JK3: [/COLOR][COLOR=Navy][COLOR=Red] models\players\minemonster sound\chars\mine\misc[/COLOR][/COLOR][COLOR=Navy] I did it, and now it works very well in my map, maybe you should did it too (the other files are in the JK3 too, so you should copy only these). I hope I could help to you:D[/COLOR]




Nozyspy

31,830 XP

30th August 2004

12 Uploads

2,853 Posts

0 Threads

#4 10 years ago

I remember when ive encountered howlers in the past even in Base JKA games, they didnt move. I thought it was because they didnt have any bot programming like normal npcs?




jk3editor

Retard Hungarian Modder

50 XP

21st August 2008

0 Uploads

1,520 Posts

0 Threads

#5 10 years ago

[COLOR=Navy]The howlers work me fine...I don't know:)[/COLOR]




LightNinja

Ninjonator

50 XP

22nd March 2003

0 Uploads

922 Posts

0 Threads

#6 10 years ago

I think they work fine in SP (thats where jk3editor is trying them) but not in MP.




lordzapharos

Kleptoleech - Hide your money!

50 XP

1st September 2006

0 Uploads

45 Posts

0 Threads

#7 10 years ago

I am using vanilla JK3 with 1.01 Patch and Gtk Radiant 1.4.0 installed. This is an SP map.

In my base folder, I have [copied from JK2]:

models\players\minemonster

and

sound\chars\mine\misc

In the minemonster folder I have animation.cfg, animsounds.cfg, minemonster.jpg, minemonster.gla, model.glm, and model_default.skin

In the misc folder I have these MPEG files: bite1, bite2, bite3, bite4, death1, death2, death3, miss1, miss2, miss3, miss4, pain25, pain50, pain75, pain100, scuttle1, scuttle2, scuttle3, scuttle4, and scuttle5.

When I load up the vanilla game, I enable cheats and use the code "npc spawn minemonster". The little minemonster guy DOES attack my character when I am close, DOES play all animations/sounds correctly, and DOES run when I run. But it stops about one jedi-width away from me if I am not moving. I have never had trouble with howlers moving, for reference.

I have tried making a new NPC file but it doesn't seem to affect the problem whatsoever...

EDIT!

I also tried making a basic map (1 room, 1 light, etc.) that had minemonsters in it. Whether spawned by a trigger or the console, these little NPC's just won't do what they're supposed to...