Model Problems (Shaders) -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 13 years ago

Hi. Back again with another problem. This one has to do with using JO models in JA. My Mace Windu Model (Courtesy of Jedimoves.com), is missing textures when loaded. I haven't tried all of my models, but I must assume the problem remains with them too. All the parts show up, but Mace has silver stuff on and in the console it says something to the effect of "Missing Shader". So, how can I rectify this problem?

Help much appreciated. Thank you in advance.




Guest

I didn't make it!

0 XP

 
#2 13 years ago

I return with more detailed information in the hopes of an answer. I haven't waited long I know, but the sooner I supply the information, the shorter I have to wait!

Anyways, upon spawning Mace Windu, I get these messages:

R_LoadMDXM: Converting JK2model models/players/samuel_l/model.glm Warning: couldn't find image for shader models/players/samuell/hips.jpg Warning: couldn't find image for shader models/players/samuell/hips_belt.jpg Warning: couldn't find image for shader models/players/samuell/torso.jpg Warning: couldn't find image for shader models/players/samuell/hands.jpg Warning: couldn't find image for shader models/players/samuell/head.jpg Warning: couldn't find image for shader models/players/samuell/legs.jpg Warning: couldn't find image for shader models/players/samuell/robe.jpg

And that's it in its entirety. Much more specific, huh? Again, I eagerly and thankfully await your assistance.




Inyri Forge VIP Member

[Insert User Title Here]

55 XP

15th March 2005

0 Uploads

25,940 Posts

0 Threads

#3 13 years ago

Is there a .surf file in it? It's probably because the skinner only skinned the surfaces he wanted and turned the rest off. JA doesn't really read .surf files (except in rare cases) so you'll need to turn extra surfaces off in the .skin file.




.The Deviant

Second Tier Wise-ass

50 XP

6th March 2005

0 Uploads

1,444 Posts

0 Threads

#4 13 years ago

Or, it could be whatever GFX file you're using was a custom one and not put ingame.




Inyri Forge VIP Member

[Insert User Title Here]

55 XP

15th March 2005

0 Uploads

25,940 Posts

0 Threads

#5 13 years ago

I'm pretty sure it's not. I've worked with with the Mace Windu skin from JO -- the base model has a lot of surfaces that were turned off (cloak, etc) and JA doesn't read the SURF files very well.




.The Deviant

Second Tier Wise-ass

50 XP

6th March 2005

0 Uploads

1,444 Posts

0 Threads

#6 13 years ago

although i never used SURF files, i never got them. i made multiple skin files: Model_default Model_robed Model_On-crack ETC....what i do is just the *off thing.




Inyri Forge VIP Member

[Insert User Title Here]

55 XP

15th March 2005

0 Uploads

25,940 Posts

0 Threads

#7 13 years ago

SURF files are the equivalent of *off in JO, I think. Actually until recently I thought SURF files were totally useless in JA. I hate being wrong... :P




Guest

I didn't make it!

0 XP

 
#8 13 years ago

So basically I should turn off the surfaces giving me trouble? I can do that. Thanks a lot. Just for the record, I dont' think there are any SURF files anywhere, but I'll check. Thank you again.