My custom saber shaders never work -1 reply

Please wait...

Exodus

Wisdom begins in wonder

50 XP

20th February 2007

0 Uploads

162 Posts

0 Threads

#1 9 years ago

Ok I've made plenty of my own custom saber and sword models, yet for no apparent reason i can never get the shaders the work on any of them, I've tried countless techniques searched through the internet yet nothing seems to work, I use setting from other weapon shaders that i know work (obviously changing the path to fit my model) i even when as far as to use the setting of sahders from my player skins but it never works and it's getting frustrating. and yes ive even tried the shader program that comes with the SDK.

If anyone has ideas of what the hell is wrong please help or if i really must ill send you the .PK3 and see if you can fix it, cause im all out of ideas




DiNeRo

modeler & skinner

50 XP

16th May 2008

0 Uploads

217 Posts

0 Threads

#2 9 years ago

are you putting the shaders onto textures and not onto objects? if so i dont know what could be wrong, try posting the .shader file here




Exodus

Wisdom begins in wonder

50 XP

20th February 2007

0 Uploads

162 Posts

0 Threads

#3 9 years ago
DiNeRo;4872693are you putting the shaders onto textures and not onto objects? if so i dont know what could be wrong, try posting the .shader file here

as i said i have made skins that shader have successfully worked on.

heres the .shader models/weapons2/F32/Blade { { map models/weapons2/F32/Blade rgbGen lightingDiffuse } { map models/weapons2/F32/Blade_glow blendFunc GL_SRC_ALPHA GL_ONE detail glow alphaGen identity } { map models/weapons2/F32/Blade_spec blendFunc GL_SRC_ALPHA GL_ONE detail alphaGen lightingSpecular } }

models/weapons2/F32/Bolt { { map models/weapons2/Polearm/Bolt blendFunc GL_ONE GL_ZERO detail rgbGen lightingDiffuse } }

models/weapons2/Polearm/Hilt {

{ map models/weapons2/F32/Hilt blendFunc GL_ONE GL_ZERO detail rgbGen lightingDiffuse } }

i made sure that the capital letters match up as well