Npc Spawning with Entities and a Server Problem -1 reply

  • 1
  • 2

Please wait...

HyperionIV

I'm too hot to Post

50 XP

2nd June 2010

0 Uploads

30 Posts

0 Threads

#1 8 years ago

Hello, I have 2 questions.

1-)When I upload my modded ffa3 to server machine (which is far away), server gets screwed up, I cannot ping server etc... What can go wrong here? note: I made a pk3 file which has directory "maps/mp/ffa3.bsp" and uploaded it.

2-)How can I create a npc spawn node, a button that spawns npc, with entities? Say, I want the button at coords (X1 Y1 Z1) and spawned npc at (X2 Y2 Z2) Can you give one specified example please...

Thanks for reading.




Sato

I just changed my sig 0.0

50 XP

17th December 2008

0 Uploads

389 Posts

0 Threads

#2 8 years ago

@ #1) You need to give us some more detailed info. Are u saying that the server is not running?

@ 2) Are u using lugormod or something or are u useing a Hex Editor?




Raz0r

Worse than most terrible

50 XP

27th September 2006

0 Uploads

6,737 Posts

0 Threads

#3 8 years ago

I believe he's using the famed 'map modding' technique.

The server should run fine. Upload the map, take the server down, start it up again, load the map..works the same as any other map.




~*Seto*~

Trapped in the interchet

50 XP

19th October 2007

0 Uploads

334 Posts

0 Threads

#4 8 years ago

If the server works fine without the mod but fails with it, then you messed up somewhere in your mod.




HyperionIV

I'm too hot to Post

50 XP

2nd June 2010

0 Uploads

30 Posts

0 Threads

#5 8 years ago

1-)Map works when I open it on my machine. What part can cause error with server here?

2-)I'm not using lugor mod, using map modding technique. With example, I meant the syntax of relevant classname etc.

Thanks for answers :)




~*Seto*~

Trapped in the interchet

50 XP

19th October 2007

0 Uploads

334 Posts

0 Threads

#6 8 years ago

But does the server work without the map?




Raz0r

Worse than most terrible

50 XP

27th September 2006

0 Uploads

6,737 Posts

0 Threads

#7 8 years ago

Really not sure why the map won't work on the external server, as you using it locally proves it does work server-side..




HyperionIV

I'm too hot to Post

50 XP

2nd June 2010

0 Uploads

30 Posts

0 Threads

#8 8 years ago

1-)Server is fine without using my map mod. What parts of modding are relevant with server side, causing server to crash?

2-)Any help?

Thanks for answers




Raz0r

Worse than most terrible

50 XP

27th September 2006

0 Uploads

6,737 Posts

0 Threads

#9 8 years ago

When you say the external server crashes, do you mean an actual crash, or an error? Can you check the logs?




~*Seto*~

Trapped in the interchet

50 XP

19th October 2007

0 Uploads

334 Posts

0 Threads

#10 8 years ago

What mod are you using locally, and what mod on the server?




  • 1
  • 2