pk3 or a ui problem -1 reply

  • 1
  • 2

Please wait...

lassev

Degenerate scripter

50 XP

21st June 2004

0 Uploads

847 Posts

0 Threads

#11 14 years ago

Well, either you have a typo in the exec command line (in the ui file), or there's something wrong with your gamestart.cfg.

Can't think of anything else, really. You could paste here the appropriate portion of the ui file (maybe just the part containing that particular next button and not the whole file this time), and recheck the gamestart.cfg is in the pk3 root (mod folder root), it's not gamestart.cfg.txt, and that the map bsp_name line inside it is free of typos.




mike elf

:)

50 XP

12th January 2005

0 Uploads

83 Posts

0 Threads

#12 14 years ago

This is the end for my newgame.menu file: // BEGIN button itemDef { name next_glow group mods style WINDOW_STYLE_SHADER rect 455 444 130 24 background "gfx/menus/menu_buttonback" // Frame around button forecolor 1 1 1 1 visible 0 decoration } itemDef { name begin game group none text @MENUS_[COLOR="Red"]BEGIN[/COLOR] descText @MENUS_[COLOR="red"]BEGIN[/COLOR]_DESC type ITEM_TYPE_BUTTON style WINDOW_STYLE_EMPTY rect 455 444 130 24 font 3 textscale 1 textalignx 65 textaligny -1 textalign ITEM_ALIGN_CENTER textstyle 3 forecolor 1 .682 0 1 visible 1 action { play "sound/interface/button1.wav" setcvar g_char_model "[COLOR="red"]kyle[/COLOR]" setcvar g_char_skin_head "[COLOR="Red"]model_default[/COLOR]" setcvar g_char_skin_torso "[COLOR="red"]model_default[/COLOR]" setcvar g_char_skin_legs "[COLOR="red"]model_default[/COLOR]" setcvar g_char_color_red "255" setcvar g_char_color_green "255" setcvar g_char_color_blue "255" setcvar snd "[COLOR="red"]kyle[/COLOR]" setcvar sex "[COLOR="red"]m[/COLOR]" close all exec "exec gamestart.cfg" } mouseEnter { show next_glow } mouseExit { hide next_glow } }

} }

ive editted the ones in red. i dont have a gamestart.cfg file in my pk3 root, but neither has the Nina:Genisis mod. I really should shouldnt i ...




mike elf

:)

50 XP

12th January 2005

0 Uploads

83 Posts

0 Threads

#13 14 years ago

I just downloaded sydnicate and looked at the pk3 - it had a gamestart.cfg file. copied it into my pk3 as map lvl1, and everything works fine now :D thanks one final thing on this: it says theres an error in newgame.menu line 624, which is this: setcvar g_char_color_red "255" it doesnt seem to affect anything but should i worry about this?




lassev

Degenerate scripter

50 XP

21st June 2004

0 Uploads

847 Posts

0 Threads

#14 14 years ago

Hmm... I can't tell why it would give that error message. I can't spot anything wrong. I doubt the Kyle model even supports player tint, so in that sense those _color lines could be redundant, and you might even be able to remove them. You could try that, and see if it removes the error message or just generates a new one. Might be worth a shot; it would take but minutes to test it, after all. Nobody like error messages, after all.

Nina does have a gamestart.cfg, but for some reason it's not inside the pk3, but is unzipped straight to the mod folder, when you decompress the mod. Actually Larry seems to have placed some extra stuff in the file, which might be worth studying, depending on your interests...




mike elf

:)

50 XP

12th January 2005

0 Uploads

83 Posts

0 Threads

#15 14 years ago

hmm i removed the color lines and it got rid of the error message so its all good now oh yeah i never noticed the nina:genisis .cfg! g_saber_type "single" - obviously the saber type g_saber "single_10" - not sure? perhaps the width of the saber - or hilt no. g_saber_color "blue" - blade color I think ill stick something like that in mine:)




  • 1
  • 2