Question about a Radiant error message -1 reply

Please wait...

Gil-Dagor

I don't spend enough time here

50 XP

24th September 2003

0 Uploads

16 Posts

0 Threads

#1 12 years ago

OK. I'm working on a map. When I compile it, it goes fine, but when I try to load it in the game, it gives me the error "MAX_SUBMODELS exceeded." I'm not sure what this means; maybe it means there's too many models in the map? :confused: I thought it would be a good idea to check if anyone knew what it meant before I went around deleting models. :lol:




Guest

I didn't make it!

0 XP

 
#2 12 years ago

I used to think that you were a gibbering idiot. Now, after reading your latest post, I have a much lower opinion of you. You must have a very large brain to hold such a vast amount of sheer ignorance. However, I'll consider letting you have the last word if you guarantee it will be your last. Oh well, as the late Douglas Adams said: "You live and learn. At any rate, you live."




iswer

Mapper, Modeller, Musician

50 XP

18th April 2004

0 Uploads

1,601 Posts

0 Threads

#3 12 years ago

quoted from a tutorial from map-center.com:

'Believe it or not, the error is more related to entities, not models. You have two kinds of entities; brush entities and 'right-click' entities.

Brush entities :- A brush entity just that, an entity that is made with a brush or several brushes. For example, you draw a 'common/trigger' brush and then turn it into a trigger_multiple. That's a brush entity. Other brush entities are trigger_push, func_trains, func_buttons, func_bobbing, func_pendulum, func_plat... you get the message. Correct me if I'm wrong, but I think you're limited to 255 brush entities. If you exceed that amount, you'll get the 'MAX_SUBMODLES exceeded' error. Keep in mind that you can make ONE brush entity out of SEVERAL brushes, and it only counts as one.

'Right-click' entities :- I don't know the technical name for these, but I call 'em 'right-click' entities. You right-click and create an entity without associating it with a brush. For example, you right click somewhere on your map and select 'Target' > 'target_position'. Some other examples are ammo items, weapon items, path_corner, target_speaker, target_give, target_kill, misc_model, etc. I haven't hit the limit on these yet, and I've heard that there really isn't a limit here (but I bet they're wrong). I'd guess the limit is probably around 1024 or something like that. But on that note, you can only have 255 visible model entities in a single vis portal or strange things will happen... You'll fire your weapon but you won't see projectiles or explosions, ammo/weapons/health items will vanish before your eyes or simply never respawn yet you can walk over where it should have been and receive the item, ...strange stuff.

If there's over 255 visible models, the ones created after model# 255 will not be drawn until some previous ones enter an unseen vis portal.

BOTTOM LINE: Reduce the number of 'brush' entities to something under 255 and your map will work again. '




TubbyTim

Mapper, skinner, n00b modeler

50 XP

31st May 2005

0 Uploads

578 Posts

0 Threads

#4 12 years ago

I have a question for you Iswer. Could this cause the SV_SetBrushModel: NULL error I was/am getting with my map?




iswer

Mapper, Modeller, Musician

50 XP

18th April 2004

0 Uploads

1,601 Posts

0 Threads

#5 12 years ago

no, i dont think so. youll get the "SV_SetBrushModel: NULL" -error when a entity is funced up and have wrong 'keys' and 'values', i think. btw.. i didnt get your map..




TubbyTim

Mapper, skinner, n00b modeler

50 XP

31st May 2005

0 Uploads

578 Posts

0 Threads

#6 12 years ago

O ok... Because I just added hint brushes outside of the main buildings to reduce some stuff and added more caulk, etc. And I know I haven't been able to get to my grandpa's lately. (My upload computer of choice lol. (Dsl)) I'll get it to you as soon as I can... sorry for all the delays. But it's kind of good because I added more stuff...again lol. -Tim




iswer

Mapper, Modeller, Musician

50 XP

18th April 2004

0 Uploads

1,601 Posts

0 Threads

#7 12 years ago

i dont that can cause your problem.. but try send your map as soon as possible, and ill probably fix it.