"No worldspawn in map" problem -1 reply

Please wait...

HyperionIV

I'm too hot to Post

50 XP

2nd June 2010

0 Uploads

30 Posts

0 Threads

#1 8 years ago

I'll cut this short.

-When I try to open the map, this error shows up. -I opened .bsp with text editor, and saw that worldspawn entity is correct -I imported the map into an empty map, and saw that all brushes have turned into "trigger_hurt", after I placed a trigger_hurt into the map.

But I CAN'T turn them back into worldspawn. It says "Cannot change 'classname' key back to worldspawn."

It is not vital since I backup'ed the map yesterday, so little work has to be done again. But for people who encounter this error in the future, I seek your help.




Jonny2199

Click >HERE< to find an idiot.

50 XP

18th September 2005

0 Uploads

1,046 Posts

0 Threads

#2 8 years ago

Searched around a bit and found out someone on an Enemy Territory forum that had the same issue. The response was...

It is usually caused by a bug (I guess) which causes the worldspawn entity to move to the bottom of the map file (it should be on top). If you open your map file in Notepad, you can edit the code manually to fix it (after making a backup!).

The most simple instructions were

// entity/brush 0 { "classname" "worldspawn"

Whereas the most complex ones involved a load of various settings...

// entity 0 { "_mingridlight" "56" "_minvertexlight" "18" "ambient" "18" "_blocksize" "1024" "gridsize" "256 256 128" "_color" "0.8 0.9 1.0" "classname" "worldspawn" "mapcoordsmins" "-768 1664" "mapcoordsmaxs" "7296 -6400"

Obviously these settings would vary from map to map, but it gives an idea of what to do, yes? It seems to occur most frequently when the first brush you put down is changed (to a door, for example). Hope this helps.




HyperionIV

I'm too hot to Post

50 XP

2nd June 2010

0 Uploads

30 Posts

0 Threads

#3 8 years ago

Thank you for answer.

First wrong of mine was doing something with .bsp. This has nothing to do with .bsp. Opened .map with text editor and placed worldspawn entity in the first place. That's all.

But another problem is, when I turn a trigger brush into trigger_hurt, every brush turns into trigger_hurt.

Any ideas how to fix it?




eezstreet

Lord of the .DCC files

50 XP

16th June 2008

0 Uploads

2,662 Posts

0 Threads

#4 8 years ago

HyperionIV;5391148

But another problem is, when I turn a trigger brush into trigger_hurt, every brush turns into trigger_hurt.

Any ideas how to fix it?

Press ESC, and -only- select the brush you want to turn into a trigger.

Or, better yet, since you seem to be having other bugs, try getting a different version of Radiant.




Guest

I didn't make it!

0 XP

 
#5 8 years ago

looks like you have physically set every single one of your brushes to worldspawn (which is how it appears in radiant but isn't actually how it will appear in notepad.




HyperionIV

I'm too hot to Post

50 XP

2nd June 2010

0 Uploads

30 Posts

0 Threads

#6 8 years ago

Ok, I solved it.

I was manipulating classname with entities window, which casued this thing. The way humans do (which is right-clicking to the brush) fixes it.

Thank you all.