Radiant Large Map Settings -1 reply

Please wait...

t3h JaKaL

Modify EVERYTHING!!

50 XP

16th April 2007

0 Uploads

83 Posts

0 Threads

#1 11 years ago

Now I noticed that people making the flight maps can make some nice sized maps, yet it seems that Radiant doesnt want to compile a map that large, someone told me that there is a way to adjust the max map size somehow to make maps like fsf, doa flight and that FF7 map possible. So does anyone here know what and where to edit so that the default map size can be overridden?




Guest

I didn't make it!

0 XP

 
#2 11 years ago

It should still compile. Just take note that it might take 15-60 minutes depending on your RAM.




Szico VII

We want FF7-2/remake!

50 XP

14th September 2003

0 Uploads

1,683 Posts

0 Threads

#3 11 years ago

There is no real 'default' size, but here are a few of the common worldspawn keys that larger maps usually have.

_blocksize 4096 (or more) - This one makes VIS data less complex by chopping up the map into larger areas. This way, your compile is faster. Also results in better fps on large open maps.

distancecull (above 12000) This increases the distance a player can see before the terrain gets chopped off or culled' default is 12000.

_lightmapscale 2 (or higher) When maps get big the lightmap data (i.e set of textures used to generate the lighting ) exceeds JK£'s limit and the map just goes wrong (lots of wierd errors) so default is 1, large maps usually have bigger values which decreases light quality but that's the price you pay.

gridsize 128 128 256 (64 64 128 default) - This one changes the size of lightrid data, i.e the section of your light compile which lights things by dynamic light such as your saber glow. Its usually safe to increase this as it's not easily noticeable at larger values.

As for the actual compile:

-lomem (a BSP switch in the light stage) makes the compiler use less memory when compiling the map. Is slower but allows more complex maps to be calculated without your PC running out of memory and giving you a safe memory allocation (safe_malloc) error.




Jedi_Mediator

The Force is my Guide

50 XP

4th August 2005

0 Uploads

280 Posts

0 Threads

#4 11 years ago

For whatever reason, distancecull never works for me. Never. That MAX_MAP_DISTANCE error still preys on me.




Omegasigma

Mapper and concept artist

50 XP

16th March 2006

0 Uploads

1,484 Posts

0 Threads

#5 11 years ago

i use culldistance usually in that case




t3h JaKaL

Modify EVERYTHING!!

50 XP

16th April 2007

0 Uploads

83 Posts

0 Threads

#6 11 years ago

ok , just so I make sure I got this right. I would need to edit the world spawn keys and values as follows:

Key: _blocksize Value: 4096

Key: distancecull Value: 12000*default*(actual value added is larger depending on the size of the map and line of sight)

Key: _lightmapscale Value: 2 (or higher)

Key: gridsize Value: 128 128 256

Then compile the map using the -lowmem compiler option.

Right?

In my experiences there is no such thing as stupid questions, only stupid mistakes made because of not asking them. :D




ƒul*£ruM

I'm too Post to cool.

50 XP

24th November 2006

0 Uploads

449 Posts

0 Threads

#7 11 years ago

t3h JaKaL;4019697ok , just so I make sure I got this right. I would need to edit the world spawn keys and values as follows:

Key: _blocksize Value: 4096

Key: distancecull Value: 12000*default*(actual value added is larger depending on the size of the map and line of sight)

Key: _lightmapscale Value: 2 (or higher)

Key: gridsize Value: 128 128 256

Then compile the map using the -lowmem compiler option.

Right?

In my experiences there is no such thing as stupid questions, only stupid mistakes made because of not asking them. :D

I personally would suggest using a fog, so the cull isn't very obvious. And the value for your cull should be 12000




Szico VII

We want FF7-2/remake!

50 XP

14th September 2003

0 Uploads

1,683 Posts

0 Threads

#8 11 years ago

It's -lomem not lowmem.

And MAX_MAP_DISTANCE isn't caused by distancecull. You should try chopsize 4096 which reduces the size of the BSP leaves by allowing them to be bigger.

There's no point using distancecull 12000 as that is the default option. You should set a higher value.