Script problem ;/ -1 reply

  • 1
  • 2

Please wait...

Guest

I didn't make it!

0 XP

 
#1 10 years ago

Hi did someone help me i cant create script in my map ;/ i follow this tutorial tutorials but when i compile my map this script dont work :uhoh:. Did someone can give me map source with this script where is working ?




Guest

I didn't make it!

0 XP

 
#2 10 years ago

I'm presuming you've hooked up a trigger_multiple to a target_scriptrunner, if not, you've probably found your problem.

If you've already done this and your getting a 'cannot find script.IBI' error in the console then make sure your target_scriptrunner has a:

Key: usescript Value: map_name/script And,

Key: count Value: -1 (If you want the script to be infinately useable)

Your map's pk3 should have a folder called "Scripts" with your 'script.IBI' placed inside the sub-folder 'map_name' . Compiling your scripts to base/scripts also works, but it's always good to get into the habit of putting everything inside the pk3 less you forget a file and end up releasing it to the public.

If this doesn't work, then it's a problem with your actual script. Post the code here so I can have a look at it.




lassev

Degenerate scripter

50 XP

21st June 2004

0 Uploads

847 Posts

0 Threads

#3 10 years ago

If the usescript points to "map_name/script" then there needs to be a subfolder of that name (map_name) under "scripts".




Guest

I didn't make it!

0 XP

 
#4 10 years ago

Schoolboy error. *edits*




Guest

I didn't make it!

0 XP

 
#5 10 years ago

:/ still dont work look at my script I want set force jump to level 1 ofc for player ;p //Generated by BehavEd rem ( "comment" ); set ( /*@SET_TYPES*/ "SET_FORCE_JUMP_LEVEL", "1" ); ofc i compile it ;p




Guest

I didn't make it!

0 XP

 
#6 10 years ago

You made sure it's running on the activator?

And this is in SP right?




Guest

I didn't make it!

0 XP

 
#7 10 years ago

yes it is in sp and i check runonactivator. Did someone can send me a sample map with this easy script :P ?




Guest

I didn't make it!

0 XP

 
#8 10 years ago

ok i start create a new map with script cutscene from this tutorial CutScene Part: 1 but it wont work and i have one idea i place there source of this map and someone check my work :uhoh: my map is in attachment please help :uhoh: this attached file have my map source and .ibi file




NAB622

EAT ME!

50 XP

8th October 2005

0 Uploads

6,921 Posts

0 Threads

#9 10 years ago

You still have options. You can:

Look for other tutorials. Look at Raven's base JA scripts and see what they did. Read the ICARUS manual. :D

I doubt anyone here (myself included) will download a file and fix it. I mean, it's possible - I've done it before. However, it may take a little time to find out what's up.

Can you be more specific about what's not working? All you've said is that it doesn't work. You haven't said yet what part of it isn't. Do /developer 1 in-game before the script is supposed to run and you can see if it is running.




lassev

Degenerate scripter

50 XP

21st June 2004

0 Uploads

847 Posts

0 Threads

#10 10 years ago

Yeah. If you follow the tutorial to the letter, it works. It doesn't work if you arbitrary omit some steps. It's perfectly fine and often necessary to adapt techniques to your particular project but do that only when you know what you are doing. Until then follow tutorials meticulously or copy existing procedures as they are. Don't try to capture the spirit if you can't see the spirit.

In SP if you want to affect the player it's not necessary to run on activator. Just Affect("player") in the script.




  • 1
  • 2