Scripting camera -1 reply

Please wait...

jk3editor

Retard Hungarian Modder

50 XP

21st August 2008

0 Uploads

1,520 Posts

0 Threads

#1 10 years ago

[COLOR=Navy]Hi! I would like to make a videowith scripts, and I have a question: If I use the "FADE" camera command, how can I disable this, after I used this? I tried to do it with the CAMERA_FADE_IN, and FADE_OUT, but it doesn't worked... [/COLOR]




NAB622

EAT ME!

50 XP

8th October 2005

0 Uploads

6,921 Posts

0 Threads

#2 10 years ago

If you're in Multiplayer, you can't do that.

I don't know how to do it in single player, but it may need a set_viewtarget to set your view to a camera entity.

Just a thought. I'm probably wrong.




jk3editor

Retard Hungarian Modder

50 XP

21st August 2008

0 Uploads

1,520 Posts

0 Threads

#3 10 years ago

[COLOR=Navy]Here don't viewtarget....it's fading the all of the screen... [/COLOR]




stotto

The Internet ends at GF

50 XP

26th September 2002

0 Uploads

114 Posts

0 Threads

#4 10 years ago

You're correct that camera commands don't work in multiplayer.

Read http://www.geocities.com/kengomaps/tutorials.html to learn how to set up and work the basic camera in single player mode.

To Fade the Camera: camera ( /*@CAMERA_COMMANDS*/ FADE, < 0.000 0.000 0.000 >, 0.000, < 0.000 0.000 0.000 >, 1.000, x ); wait ( x ); (replace x with the time you want the fade to take)

To Fade the Camera back in: camera ( /*@CAMERA_COMMANDS*/ FADE, < 0.000 0.000 0.000 >, 1.000, < 0.000 0.000 0.000 >, 0.000, x ); wait ( x ); (replace x with the time you want the fade in to take)

note: in my example i only used black, a fade can be done to any color, as long as you input the proper RGB vector for it




jk3editor

Retard Hungarian Modder

50 XP

21st August 2008

0 Uploads

1,520 Posts

0 Threads

#5 10 years ago

[COLOR=Navy]Ohh..thanks!! I haven't try to set it back to 0:D:D And I can to scripting camera, I've just would like to try fade the screen:D [/COLOR]




NAB622

EAT ME!

50 XP

8th October 2005

0 Uploads

6,921 Posts

0 Threads

#6 10 years ago
stotto;4653444You're correct that camera commands don't work in multiplayer.

Yeah, I know that, I just didn't know how to do it in single player. I'm pretty clueless.

[unrelated banter] There IS a way to make cameras in multiplayer, and they function pretty much the same, but it takes a lot of extra work and workarounds. Very inefficient. Don't ask, really......it took me a few days on xfire to explain it to a friend. [/unrelated banter]




stotto

The Internet ends at GF

50 XP

26th September 2002

0 Uploads

114 Posts

0 Threads

#7 10 years ago

[@unrelated banter]But now you've got me wondering![/@unrelated banter]




NAB622

EAT ME!

50 XP

8th October 2005

0 Uploads

6,921 Posts

0 Threads

#8 10 years ago

Gah, I typo'd anyways. I said it works the same.....I meant to say it LOOKS pretty much the same. It takes so much extra work it's not even funny.