Shader Problem -1 reply

Please wait...

xsear

Xtended Service

50 XP

20th May 2006

0 Uploads

14 Posts

0 Threads

#1 11 years ago

Kay so I'm really new to this shading stuff. Well, i wanted to make the shader really count, because my first attempt didn't really make such a big difference than if i had just put it on the skin from the beginning. So i thought that if i could make some sort of glow that went from top to bottom on this X i have on the back of the skin, it would look cool. After trying around, i found a way to do this and it looked really cool in Q3ASE. Saved, did all the stuffs needed, started JA and was very dissapointed. The shader did not show up, but it wasn't the only thing that didn't show up, infact, the whole body was gone! So it was just like Head, arms and legs and nothing between them =(

I can't find anything wrong, but thats because i suck at shading =D

I have 4 bodys. I made the same type of shader for all of them except one. This is the code that shows up if i open the shaders with notepad:

models/players/xse_1/vest01 { { map models/players/xse_1/vest01_g.tga tcMod rotate 20 } { map models/players/xse_1/vest01.tga blendfunc blend } }

Heres the one i did different: models/players/xse_1/vest04 { { map models/players/xse_1/vest04_g.tga tcMod scroll 0.2 3 } { map models/players/xse_1/vest04.tga blendfunc blend } }

If i try to open any of these with ShaderEd2, i get file not found message.

Ingame its like the body is not there, i can see straight through, its like one of thoose hack skins that are around.

Anyone got any idea of whats wrong? If needed, i can post more information.




Isla Kamamee

Awkward? You bet!

50 XP

28th August 2006

0 Uploads

1,179 Posts

0 Threads

#2 11 years ago

uhm....first off, Q3ASE, AND ShaderEd will screw you over, dont use them. Learn the syntax and write it yourself. For some reason the shaders made in either cannot import into the other, they use different something...But I havent figured out what the different something is. Its something about the files they produce. They arent compatable. Learn what everything does, look at the Q3A shader manual (master sticky) and learn how to write these things for yourself. and you said those are supposed to glow? they have no glow command anywhere in them...after you learn how to do it, try rewriting them, and theyll probably work.




xsear

Xtended Service

50 XP

20th May 2006

0 Uploads

14 Posts

0 Threads

#3 11 years ago

Actually they were glowing, but in a different way =D The scroll made it look like a wave of glow went from the top to the bottom. Anyways, i found out that the problem was having different sizes on the "glowing" picture and the normal picture ^^




Isla Kamamee

Awkward? You bet!

50 XP

28th August 2006

0 Uploads

1,179 Posts

0 Threads

#4 11 years ago

lol XP I still suggest learnin it urself.