Shaders aren't displaying in GtkRadiant -1 reply

  • 1
  • 2

Please wait...

editor obi-wan

Beware the squared-chined jedi

50 XP

24th October 2002

0 Uploads

2,785 Posts

0 Threads

#1 12 years ago

I've just installed GtkRadiant 1.5.0 and I'm trying to set it up for JO and JA and none of the shaders are displaying. Instead, I get a red and black place holder saying "Shader Image Missing" or a blue and black one saying "Shader Not Found."

I've already had a look at [this thread] and tried to apply it for JO and JA, but it's not working.

I've extracted a copy of the shader files from assets0.pk3 into the shaders folder in the base folder of the game and made sure that view>show shaders option in GtkRadiant is selected.

I'm running the 1.04 patch for JO and original version of JA and have several custom .pk3 files in the base folder.

Is there something I'm forgetting to do? Ed.O.




DracoLich

~Senatu

50 XP

11th January 2006

0 Uploads

212 Posts

0 Threads

#2 12 years ago

What shaders it isnt showing, system or all shaders?




Guest

I didn't make it!

0 XP

 
#3 12 years ago

Personally, I like 1.5.0 over the other Radiants. But, 1.4.0 is easier to install and get going. It comes with all those shaders, as well.

So try 1.4.0 and see if it makes a difference.




21st July 2005

0 Uploads

2,308 Posts

0 Threads

#4 12 years ago

Did you copy the shaderlist.txt to the shaders folder?

You can also try adding the gamepack information from here: https://zerowing.idsoftware.com/svn/radiant.gamepacks/JAPack/trunk/

It'd be easier to download with a SVN viewer.




Guest

I didn't make it!

0 XP

 
#5 12 years ago

i had this problem to when i first installed 1.5. you need to goto edit>preferances and then a dialog box will show up, in it look for settings and click the + next to settings then goto paths and you need to set it like this C:/Program Files/LucasArts/Star Wars Jedi Knight Jedi Academy/GameData/ C:/Program Files/LucasArts/Star Wars Jedi Knight Jedi Outcast/GameData/

you need to do it for both JKA and JKO if it still isnt working then i dont know whats wrong




Kaito

Addicted to GF

50 XP

16th January 2007

0 Uploads

265 Posts

0 Threads

#6 12 years ago

yup yup

If what zero said doesn't work, download 1.4, and install it. Just make sure u have it on ur computer. That should fix ur problems




editor obi-wan

Beware the squared-chined jedi

50 XP

24th October 2002

0 Uploads

2,785 Posts

0 Threads

#7 12 years ago

Thanks for the great responses, all.

To answer DracoLich's question, none of the shaders are currently working.

When I click on your link, Captain Chordata, all I see is a list of folders and as I navigate through them, they appear to be exactly as how I have my own hard drive set up. All the files listed on the link are in the correct place in my base/shaders folder.

Zero Ame, I've already checked that option before posting: it's correct.

I want to run with the latest version of the program if at all possible. By the sounds of it, you're recommending I install the 1.4 version just so it places the shader files in the correct location (which they already are.) So I'm skeptical about whether it will help any.




Isla Kamamee

Awkward? You bet!

50 XP

28th August 2006

0 Uploads

1,179 Posts

0 Threads

#8 12 years ago

well, you can do that, then if you wanna, use it to compile. 1.5 has a bug (for me at least) that makes it unable to compile light...actually anything above a meta. Says its writing to junk.txt and doesnt go through any stages. Also never stops when you try the simulate old style one or wever it was called. Other than that, I dont know what you should do, youve apparently tried everything that can make it go screwy when done wrong.




Immenor

Pie incoming

50 XP

27th June 2004

0 Uploads

93 Posts

0 Threads

#9 12 years ago

Compile with a q3map front end like q3mapGUI. Its faster and gives you more control as well as the normal presets.




Guest

I didn't make it!

0 XP

 
#10 12 years ago

Try 1.4. It sounds silly, but trust me, it may help.




  • 1
  • 2